diff configure.in @ 4204:976bc19f8f6b SDL-1.2

1.2 Quartz video: Ripped out QuickDraw and QuickTime. Now we use the software path for YUV, and CoreGraphics for 2D stuff. There are several other 10.6 fixes in here, too...now we can build a 64-bit SDL for Snow Leopard!
author Ryan C. Gordon <icculus@icculus.org>
date Mon, 21 Sep 2009 06:08:23 +0000
parents 2f5e884f0a9d
children 453587d6dc87
line wrap: on
line diff
--- a/configure.in	Mon Sep 21 04:34:22 2009 +0000
+++ b/configure.in	Mon Sep 21 06:08:23 2009 +0000
@@ -2696,8 +2696,8 @@
             need_iokit_framework=yes
         fi
         if test x$enable_video_carbon = xyes -o x$enable_video_cocoa = xyes; then
-            # The Cocoa backend still needs Carbon, and the YUV code QuickTime
-            EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,QuickTime -Wl,-framework,ApplicationServices"
+            # The Cocoa backend still needs Carbon
+            EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,ApplicationServices"
             EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,Carbon"
         fi
         # If either the audio or CD driver is used, add the AudioUnit framework