diff test/configure.in @ 3293:0d60bdebed39

Fixed bug #674 Matej 2009-01-08 09:25:34 PST Hello, I maintain a cross-platform project that uses SDL. One of the users who runs OSX has told me that he has problems with linking to SDL due to missing -framework option. I think that the problem is because of this: 'sdl-config --libs' outputs '-L/opt/local/lib -lSDLmain -lSDL -Wl,-framework,Cocoa' All the options are passed to the linker except the last one. I think that the good output should be just: '-L/opt/local/lib -lSDLmain -lSDL -framework Cocoa' since those options (--libs) are passed to the linker, so the '-Wl' option is redundant and possibly harmful in this very case I use autotools with libtool to do the build... Regards, Matej
author Sam Lantinga <slouken@libsdl.org>
date Mon, 21 Sep 2009 10:23:19 +0000
parents 245a7d79577c
children 94f22808d19e
line wrap: on
line diff
--- a/test/configure.in	Mon Sep 21 09:21:00 2009 +0000
+++ b/test/configure.in	Mon Sep 21 10:23:19 2009 +0000
@@ -28,7 +28,7 @@
     *-*-darwin* )
         EXE=""
         MATHLIB=""
-        SYS_GL_LIBS="-Wl,-framework,OpenGL"
+        SYS_GL_LIBS="-framework OpenGL"
         ;;
     *-*-aix*)
         EXE=""