diff configure.in @ 5069:fd125217f00c

Separated out the minimum functionality that we need from gcc for our spinlock fallback.
author Sam Lantinga <slouken@libsdl.org>
date Fri, 21 Jan 2011 21:42:04 -0800
parents 231dbbc3e31c
children 55ff76cdbbb8
line wrap: on
line diff
--- a/configure.in	Fri Jan 21 21:35:43 2011 -0800
+++ b/configure.in	Fri Jan 21 21:42:04 2011 -0800
@@ -312,6 +312,18 @@
     if test x$have_gcc_atomics = xyes; then
         AC_DEFINE(HAVE_GCC_ATOMICS)
     fi
+
+    # See if we have the minimum operation needed for GCC atomics
+    AC_TRY_LINK([
+    ],[
+    int a;
+    __sync_lock_test_and_set(&a, 1);
+    ],[
+    have_gcc_sync_lock_test_and_set=yes
+    ])
+    if test x$have_gcc_sync_lock_test_and_set = xyes; then
+        AC_DEFINE(HAVE_GCC_SYNC_LOCK_TEST_AND_SET)
+    fi
 fi
 
 # Standard C sources