diff configure.in @ 731:faaa676b20ef

*** empty log message ***
author Sam Lantinga <slouken@libsdl.org>
date Mon, 06 Oct 2003 09:03:02 +0000
parents 6b3dfe0198bb
children 22dbf364c017
line wrap: on
line diff
--- a/configure.in	Mon Oct 06 08:34:08 2003 +0000
+++ b/configure.in	Mon Oct 06 09:03:02 2003 +0000
@@ -335,11 +335,11 @@
             esd_lib_spec=`echo $ESD_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libesd.so.*/'`
             esd_lib=`ls $esd_lib_spec | head -1 | sed 's/.*\/\(.*\)/\1/'`
             echo "-- $esd_lib_spec -> $esd_lib"
-            if test x$enable_dlopen != xyes && \
+            if test x$use_dlopen != xyes && \
                test x$enable_esd_shared = xyes; then
                 AC_MSG_ERROR([You must have dlopen() support and use the --enable-dlopen option])
             fi
-            if test x$enable_dlopen = xyes && \
+            if test x$use_dlopen = xyes && \
                test x$enable_esd_shared = xyes && test x$esd_lib != x; then
                 CFLAGS="$CFLAGS -DESD_SUPPORT -DESD_DYNAMIC=\$(esd_lib) $ESD_CFLAGS"
                 AC_SUBST(esd_lib)
@@ -385,11 +385,11 @@
                 arts_lib_spec=`echo $ARTSC_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libartsc.so.*/'`
                 arts_lib=`ls $arts_lib_spec | head -1 | sed 's/.*\/\(.*\)/\1/'`
                 echo "-- $arts_lib_spec -> $arts_lib"
-                if test x$enable_dlopen != xyes && \
+                if test x$use_dlopen != xyes && \
                    test x$enable_arts_shared = xyes; then
                     AC_MSG_ERROR([You must have dlopen() support and use the --enable-dlopen option])
                 fi
-                if test x$enable_dlopen = xyes && \
+                if test x$use_dlopen = xyes && \
                    test x$enable_arts_shared = xyes && test x$arts_lib != x; then
                     CFLAGS="$CFLAGS -DARTSC_SUPPORT -DARTSC_DYNAMIC=\$(arts_lib) $ARTSC_CFLAGS"
                     AC_SUBST(arts_lib)
@@ -1556,10 +1556,10 @@
 dnl Check for the dlfcn.h interface for dynamically loading objects
 CheckDLOPEN()
 {
-    AC_ARG_ENABLE(dlopen,
-[  --enable-dlopen         use dlopen for shared object loading [default=no]],
-                  , enable_dlopen=yes)
-    if test x$enable_dlopen = xyes; then
+    AC_ARG_ENABLE(sdl-dlopen,
+[  --enable-sdl-dlopen     use dlopen for shared object loading [default=yes]],
+                  , enable_sdl_dlopen=yes)
+    if test x$enable_sdl_dlopen = xyes; then
         AC_MSG_CHECKING(for dlopen)
         use_dlopen=no
         AC_TRY_COMPILE([