diff configure.in @ 4184:ed5913896653 SDL-1.2

Disable Sound Manager support on Mac OS X. It's an OS 9 API that was exposed via Carbon, but is gone in the 10.6 SDK. OS X uses CoreAudio. We only had it in here for debugging purposes anyhow, as SDL would never use it unless forced to with an environment variable. It remains in SDL for OS 9, of course.
author Ryan C. Gordon <icculus@icculus.org>
date Sat, 12 Sep 2009 12:50:25 +0000
parents a6f635e5eaa6
children cb2d5514efb3
line wrap: on
line diff
--- a/configure.in	Sat Sep 12 06:25:36 2009 +0000
+++ b/configure.in	Sat Sep 12 12:50:25 2009 +0000
@@ -2626,8 +2626,6 @@
         if test x$enable_audio = xyes; then
             AC_DEFINE(SDL_AUDIO_DRIVER_COREAUDIO)
             SOURCES="$SOURCES $srcdir/src/audio/macosx/*.c"
-            AC_DEFINE(SDL_AUDIO_DRIVER_SNDMGR)
-            SOURCES="$SOURCES $srcdir/src/audio/macrom/*.c"
             have_audio=yes
         fi
         # Set up files for the joystick library