diff configure.in @ 1611:ec3466b08f17

Fixed bug #177 The attached patch changes configure.in to use "-framework FOO" instead of "-Wl,-framework,FOO". This avoid some issues with certain versions of libtool that do not handle -framework properly. Some versions of libtool will try to reorder the two parts of the option, or render the 2nd part of the argument to the relative path of a non-existent library. Note: It is not enough if SDL uses a version of libtool that does this correctly, because these -framework options show up in "sdl-config --libs". Hence, some 3rd party apps which still ship with an old libtool have troubles compiling under Mac OS X.
author Sam Lantinga <slouken@libsdl.org>
date Fri, 24 Mar 2006 05:11:51 +0000
parents d91c02552377
children f12379c41042
line wrap: on
line diff
--- a/configure.in	Fri Mar 24 03:49:37 2006 +0000
+++ b/configure.in	Fri Mar 24 05:11:51 2006 +0000
@@ -1444,9 +1444,9 @@
         AC_DEFINE(SDL_VIDEO_OPENGL)
         case "$host" in
             *-*-darwin*)
-                EXTRA_LDFLAGS="$EXTRA_LDFLAGS -framework OpenGL"
+                EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,OpenGL"
                 # The following is probably not available in Darwin:
-                EXTRA_LDFLAGS="$EXTRA_LDFLAGS -framework AGL"
+                EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,AGL"
         esac
     fi
 }
@@ -2342,7 +2342,7 @@
         if test x$enable_joystick = xyes; then
             AC_DEFINE(SDL_JOYSTICK_IOKIT)
             SOURCES="$SOURCES $srcdir/src/joystick/darwin/*.c"
-            EXTRA_LDFLAGS="$EXTRA_LDFLAGS -framework IOKit"
+            EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,IOKit"
             have_joystick=yes
         fi
         # Set up files for the cdrom library
@@ -2368,16 +2368,16 @@
         EXTRA_CFLAGS="$EXTRA_CFLAGS -fpascal-strings"
         SDL_LIBS="-lSDLmain $SDL_LIBS"
         if test x$enable_video_cocoa = xyes; then
-            EXTRA_LDFLAGS="$EXTRA_LDFLAGS -framework Cocoa"
+            EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,Cocoa"
         fi
         if test x$enable_video_carbon = xyes -o x$enable_video_cocoa = xyes; then
             # The Cocoa backend still needs Carbon, and the YUV code QuickTime
-            EXTRA_LDFLAGS="$EXTRA_LDFLAGS -framework QuickTime -framework ApplicationServices"
-            EXTRA_LDFLAGS="$EXTRA_LDFLAGS -framework Carbon"
+            EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,QuickTime -Wl,-framework,ApplicationServices"
+            EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,Carbon"
         fi
         # If either the audio or CD driver is used, add the AudioUnit framework
         if test x$enable_audio = xyes -o x$enable_cdrom = xyes; then
-            EXTRA_LDFLAGS="$EXTRA_LDFLAGS -framework AudioToolbox -framework AudioUnit"
+            EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,AudioToolbox -Wl,-framework,AudioUnit"
         fi
         ;;
     *-*-mint*)
@@ -2519,13 +2519,13 @@
 case "$ARCH" in
   macosx)
     if test x$enable_video = xyes -a x$enable_video_cocoa = xyes; then
-      SDL_LIBS="$SDL_LIBS -framework Cocoa"
+      SDL_LIBS="$SDL_LIBS -Wl,-framework,Cocoa"
     fi
     if test x$enable_video = xyes -a x$enable_video_carbon = xyes; then
-      SDL_LIBS="$SDL_LIBS -framework Carbon"
+      SDL_LIBS="$SDL_LIBS -Wl,-framework,Carbon"
     fi
     if test x$enable_video = xyes -a x$enable_video_opengl = xyes; then
-      SDL_LIBS="$SDL_LIBS -framework OpenGL"
+      SDL_LIBS="$SDL_LIBS -Wl,-framework,OpenGL"
     fi
     # Evil hack to allow static linking on Mac OS X
     SDL_STATIC_LIBS="\${exec_prefix}/lib/libSDLmain.a \${exec_prefix}/lib/libSDL.a"