diff configure.in @ 868:e805075f6d94

sed, it's two, two commands in one!
author Sam Lantinga <slouken@libsdl.org>
date Wed, 03 Mar 2004 06:56:04 +0000
parents 92615154bb68
children 89666943c598
line wrap: on
line diff
--- a/configure.in	Tue Mar 02 19:38:55 2004 +0000
+++ b/configure.in	Wed Mar 03 06:56:04 2004 +0000
@@ -298,7 +298,7 @@
             AC_ARG_ENABLE(alsa-shared,
 [  --enable-alsa-shared     dynamically load ALSA audio support [default=yes]],
                           , enable_alsa_shared=yes)
-            alsa_lib=`ls /usr/lib/libasound.so.* | head -1 | sed 's/.*\/\(.*\)/\1/'`
+            alsa_lib=`ls /usr/lib/libasound.so.* | sed 's/.*\/\(.*\)/\1/; q'`
             if test x$use_dlopen != xyes && \
                test x$enable_alsa_shared = xyes; then
                 AC_MSG_ERROR([You must have dlopen() support and use the --enable-dlopen option])
@@ -356,7 +356,7 @@
 [  --enable-esd-shared     dynamically load ESD audio support [default=yes]],
                           , enable_esd_shared=yes)
             esd_lib_spec=`echo $ESD_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libesd.so.*/'`
-            esd_lib=`ls $esd_lib_spec | head -1 | sed 's/.*\/\(.*\)/\1/'`
+            esd_lib=`ls $esd_lib_spec | sed 's/.*\/\(.*\)/\1/; q'`
             echo "-- $esd_lib_spec -> $esd_lib"
             if test x$use_dlopen != xyes && \
                test x$enable_esd_shared = xyes; then
@@ -407,7 +407,7 @@
 [  --enable-arts-shared    dynamically load aRts audio support [default=yes]],
                               , enable_arts_shared=yes)
                 arts_lib_spec="$ARTSC_PREFIX/lib/libartsc.so.*"
-                arts_lib=`ls $arts_lib_spec | head -1 | sed 's/.*\/\(.*\)/\1/'`
+                arts_lib=`ls $arts_lib_spec | sed 's/.*\/\(.*\)/\1/; q'`
                 echo "-- $arts_lib_spec -> $arts_lib"
                 if test x$use_dlopen != xyes && \
                    test x$enable_arts_shared = xyes; then