diff configure.in @ 740:e70f80e98f60

Actually hook the cpuinfo module into the library. :)
author Sam Lantinga <slouken@libsdl.org>
date Tue, 18 Nov 2003 02:16:57 +0000
parents 22dbf364c017
children 528a52626680
line wrap: on
line diff
--- a/configure.in	Tue Nov 18 01:27:06 2003 +0000
+++ b/configure.in	Tue Nov 18 02:16:57 2003 +0000
@@ -226,6 +226,15 @@
 else
     CFLAGS="$CFLAGS -DDISABLE_FILE"
 fi
+AC_ARG_ENABLE(cpuinfo,
+[  --enable-cpuinfo        Enable the cpuinfo subsystem [default=yes]],
+              , enable_cpuinfo=yes)
+if test x$enable_cpuinfo = xyes; then
+    SDL_EXTRADIRS="$SDL_EXTRADIRS cpuinfo"
+    SDL_EXTRALIBS="$SDL_EXTRALIBS cpuinfo/libcpuinfo.la"
+else
+    CFLAGS="$CFLAGS -DDISABLE_CPUINFO"
+fi
 
 dnl See if the OSS audio interface is supported
 CheckOSS()