diff configure.in @ 1367:e440d5c488c1

Fixes for BeOS and Solaris builds
author Sam Lantinga <slouken@libsdl.org>
date Fri, 17 Feb 2006 08:43:23 +0000
parents 34d9df784d84
children 00fc57bb5dc4
line wrap: on
line diff
--- a/configure.in	Thu Feb 16 23:32:39 2006 +0000
+++ b/configure.in	Fri Feb 17 08:43:23 2006 +0000
@@ -107,7 +107,7 @@
     if test x$ac_cv_func_strtod = xyes; then
         AC_DEFINE(HAVE_STRTOD)
     fi
-    AC_CHECK_FUNCS(malloc calloc realloc free getenv putenv unsetenv qsort abs bcopy memset memcpy memmove strlen strcpy strncpy strcat strncat strdup _strrev _strupr _strlwr strchr strrchr strstr itoa _ltoa _uitoa _ultoa strtol _i64toa _ui64toa strtoll atoi atof strcmp strncmp stricmp strcasecmp sscanf snprintf vsnprint sigaction setjmp nanosleep)
+    AC_CHECK_FUNCS(malloc calloc realloc free getenv putenv unsetenv qsort abs bcopy memset memcpy memmove strlen strcpy strncpy strcat strncat strdup _strrev _strupr _strlwr strchr strrchr strstr itoa _ltoa _uitoa _ultoa strtol _i64toa _ui64toa strtoll atoi atof strcmp strncmp stricmp strcasecmp sscanf snprintf vsnprintf sigaction setjmp nanosleep)
 fi
 
 if test x$have_inttypes != xyes; then
@@ -762,8 +762,10 @@
                     x11ext_lib='libXext.so'
                     ;;
                 *)
-                    x11_lib='libX11.so.6'
-                    x11ext_lib='libXext.so.6'
+                    x11_lib_spec=`echo $X_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libX11.so.*/'`
+                    x11_lib=`ls $x11_lib_spec | sed 's/.*\/\(.*\)/\1/; q'`
+                    x11ext_lib_spec=`echo $X_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libXext.so.*/'`
+                    x11ext_lib=`ls $x11ext_lib_spec | sed 's/.*\/\(.*\)/\1/; q'`
                     ;;
             esac
 
@@ -786,7 +788,6 @@
                 X_LIBS="$X_LIBS -lX11 -lXext"
             fi
 
-
             AC_DEFINE(SDL_VIDEO_DRIVER_X11)
             SOURCES="$SOURCES $srcdir/src/video/x11/*.c"
             BUILD_CFLAGS="$BUILD_CFLAGS $X_CFLAGS"
@@ -2184,7 +2185,8 @@
             SOURCES="$SOURCES $srcdir/src/loadso/beos/*.c"
             have_loadso=yes
         fi
-        # The BeOS platform requires special libraries
+        # The BeOS platform requires special setup.
+        SOURCES="$srcdir/src/main/beos/*.cc $SOURCES"
         BUILD_LIBS="$BUILD_LIBS -lroot -lbe -lmedia -lgame -ldevice -ltextencoding"
         ;;
     *-*-darwin* )