diff configure.in @ 1019:e3b3130f3af8

Date: Fri, 31 Dec 2004 04:14:09 +0900 From: Hayashi Naoyuki Subject: SDL patch for Tru64 UNIX 4.0X SDL-1.2.8 support only Tru64 5.X. This patch is for Tru64 UNIX 4.X.(tested on Tru64 UNIX 4.0G and 5.1B) SDL-1.2.8/configure.in: ld doesn't accept -pthread option. cc -pthread has same effect as -D_REENTRANT when compiling, and has same effect as -lpthread -lexc when linking. SDL-1.2.8/include/begin_code.h: Old Compaq C Compiler accept not inline but __inline. SDL-1.2.8/src/audio/SDL_mixer_MMX.c: SDL-1.2.8/src/audio/SDL_mixer_MMX.h: Old Compaq C Compiler doesn't accept //. SDL-1.2.8/src/cdrom/osf/SDL_syscdrom.c: When becoming Tru64 v5.0 from Tru64 v4.0, the arrangement of the cd-rom device was changed.
author Sam Lantinga <slouken@libsdl.org>
date Sun, 02 Jan 2005 05:05:21 +0000
parents 027688378762
children cca9aeb2934f
line wrap: on
line diff
--- a/configure.in	Mon Dec 27 20:03:53 2004 +0000
+++ b/configure.in	Sun Jan 02 05:05:21 2005 +0000
@@ -1280,12 +1280,11 @@
             pthread_lib=""
             ;;
         *-*-osf*)
+            pthread_cflags="-D_REENTRANT"
             if test x$ac_cv_prog_gcc = xyes; then
-                pthread_cflags="-D_REENTRANT"
                 pthread_lib="-lpthread -lrt"
             else
-                pthread_cflags="-pthread"
-                pthread_lib="-lpthread -lrt"
+                pthread_lib="-lpthread -lexc -lrt"
             fi
             ;;
         *)