diff configure.in @ 1402:d910939febfa

Use consistent identifiers for the various platforms we support. Make sure every source file includes SDL_config.h, so the proper system headers are chosen.
author Sam Lantinga <slouken@libsdl.org>
date Tue, 21 Feb 2006 08:46:50 +0000
parents c35c161a1100
children 1f4f09641645
line wrap: on
line diff
--- a/configure.in	Tue Feb 21 08:34:45 2006 +0000
+++ b/configure.in	Tue Feb 21 08:46:50 2006 +0000
@@ -57,10 +57,10 @@
 case "$target" in
     *-*-cygwin*)
         # We build SDL on cygwin without the UNIX emulation layer
-        CFLAGS="$CFLAGS -I/usr/include/mingw -DWIN32 -Uunix -mno-cygwin"
+        CFLAGS="$CFLAGS -I/usr/include/mingw -mno-cygwin"
         BUILD_CFLAGS="$CFLAGS \$(INCLUDE)"
         BUILD_LDFLAGS="$LDFLAGS -mno-cygwin"
-        SDL_CFLAGS="-I/usr/include/mingw -DWIN32 -Uunix -mno-cygwin"
+        SDL_CFLAGS="-I/usr/include/mingw -mno-cygwin"
         SDL_LIBS="-lSDL -mno-cygwin"
         ;;
     *)
@@ -239,11 +239,11 @@
 if test x$enable_cpuinfo != xyes; then
     AC_DEFINE(SDL_CPUINFO_DISABLED)
 fi
-AC_ARG_ENABLE(assembly-blit,
-AC_HELP_STRING([--enable-asm-blit], [Enable assembly blitters [default=yes]]),
-              , enable_asm_blit=yes)
-if test x$enable_asm_blit = xyes; then
-    AC_DEFINE(SDL_ASSEMBLY_BLITTERS)
+AC_ARG_ENABLE(assembly,
+AC_HELP_STRING([--enable-assembly], [Enable assembly routines [default=yes]]),
+              , enable_assembly=yes)
+if test x$enable_assembly = xyes; then
+    AC_DEFINE(SDL_ASSEMBLY_ROUTINES)
 fi
 
 dnl See if the OSS audio interface is supported
@@ -559,7 +559,7 @@
     AC_ARG_ENABLE(nasm,
 AC_HELP_STRING([--enable-nasm], [use nasm assembly blitters on x86 [default=yes]]),
                   , enable_nasm=yes)
-    if test x$enable_video = xyes -a x$enable_asm_blit = xyes -a x$enable_nasm = xyes; then
+    if test x$enable_video = xyes -a x$enable_assembly = xyes -a x$enable_nasm = xyes; then
         AC_PATH_PROG(NASM, nasm)
         if test x$NASM != x -a x$NASM != x'"$NASM"'; then
             AC_DEFINE(SDL_HERMES_BLITTERS)
@@ -595,7 +595,7 @@
     AC_ARG_ENABLE(altivec,
 AC_HELP_STRING([--enable-altivec], [use altivec assembly blitters on PPC [default=yes]]),
                   , enable_altivec=yes)
-    if test x$enable_video = xyes -a x$enable_asm_blit = xyes -a x$enable_altivec = xyes; then
+    if test x$enable_video = xyes -a x$enable_assembly = xyes -a x$enable_altivec = xyes; then
         have_altivec_h_hdr=no
         AC_CHECK_HEADER(altivec.h, have_altivec_h_hdr=yes)
 
@@ -2012,13 +2012,6 @@
             SOURCES="$SOURCES $srcdir/src/timer/unix/*.c"
             have_timers=yes
         fi
-        # Do any final platform setup
-        case $ARCH in
-            openbsd|netbsd)
-                # OpenBSD and NetBSD do not define "unix"
-                BUILD_CFLAGS="$BUILD_CFLAGS -Dunix"
-            ;;
-        esac
         ;;
     *-*-qnx*)
         ARCH=qnx
@@ -2221,8 +2214,7 @@
         fi
         # The MacOS X platform requires special setup.
         SDLMAIN_SOURCES="$srcdir/src/main/macosx/*.m"
-        AC_DEFINE(TARGET_API_MAC_CARBON)
-        BUILD_CFLAGS="$BUILD_CFLAGS -fpascal-strings -DMACOSX"
+        BUILD_CFLAGS="$BUILD_CFLAGS -fpascal-strings"
         SDL_LIBS="-lSDLmain $SDL_LIBS"
         if test x$enable_video_cocoa = xyes; then
             BUILD_LDFLAGS="$BUILD_LDFLAGS -framework Cocoa"
@@ -2279,8 +2271,6 @@
             fi
             have_timers=yes
         fi
-        # MiNT does not define "unix"
-        BUILD_CFLAGS="$BUILD_CFLAGS -Dunix"
         ;;
     *-riscos)
         ARCH=riscos