diff configure.in @ 3405:d5f2dd33f4eb

Merged improvements to SDL_SoftStretch() from SDL 1.2
author Sam Lantinga <slouken@libsdl.org>
date Sun, 18 Oct 2009 17:49:40 +0000
parents 2b0a3b2f2fc6
children 1756b9569141
line wrap: on
line diff
--- a/configure.in	Sun Oct 18 16:14:35 2009 +0000
+++ b/configure.in	Sun Oct 18 17:49:40 2009 +0000
@@ -204,6 +204,15 @@
     if test x$ac_cv_func_strtod = xyes; then
         AC_DEFINE(HAVE_STRTOD)
     fi
+    AC_CHECK_FUNC(mprotect,
+        AC_TRY_COMPILE([
+          #include <sys/types.h>
+          #include <sys/mman.h>
+        ],[
+        ],[
+        AC_DEFINE(HAVE_MPROTECT)
+        ]),
+    )
     AC_CHECK_FUNCS(malloc calloc realloc free getenv putenv unsetenv qsort abs bcopy memset memcpy memmove strlen strlcpy strlcat strdup _strrev _strupr _strlwr strchr strrchr strstr itoa _ltoa _uitoa _ultoa strtol strtoul _i64toa _ui64toa strtoll strtoull atoi atof strcmp strncmp _stricmp strcasecmp _strnicmp strncasecmp sscanf snprintf vsnprintf sigaction setjmp nanosleep)
 
     AC_CHECK_LIB(m, pow, [LIBS="$LIBS -lm"; EXTRA_LDFLAGS="$EXTRA_LDFLAGS -lm"])