diff configure.in @ 2567:d551e29f086b gsoc2008_force_feedback

Configure should try to use haptic on windows with directinput.
author Edgar Simo <bobbens@gmail.com>
date Thu, 31 Jul 2008 11:10:52 +0000
parents 0e63e7e4a986
children 91fd5d3cb90e
line wrap: on
line diff
--- a/configure.in	Thu Jul 31 11:06:16 2008 +0000
+++ b/configure.in	Thu Jul 31 11:10:52 2008 +0000
@@ -2331,6 +2331,13 @@
             fi
             have_joystick=yes
         fi
+        if test x$enable_haptic = xyes; then
+            if test x$have_dinput = xyes; then
+                AC_DEFINE(SDL_HAPTIC_DINPUT)
+                SOURCES="$SOURCES $srcdir/src/haptic/win32/SDL_syshaptic.c"
+                have_haptic=yes
+            fi
+        fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
             AC_DEFINE(SDL_CDROM_WIN32)