diff configure.in @ 856:d3165b90ee42

Date: Mon, 23 Feb 2004 19:00:23 +0100 From: "Juergen \"George\" Sawinski" Subject: Problems compiling libsdl with gcc 3.3 I attached another patch (configure.in.patch) that might resolv issues for some ppl finding the correct place of libartsc.so.*. (here, the output of "artsc-config --libs" contains two "-L.*", therefore the respecting arts_lib_spec contains the wrong path).
author Sam Lantinga <slouken@libsdl.org>
date Tue, 24 Feb 2004 19:22:22 +0000
parents 96ba4eab74fb
children 92615154bb68
line wrap: on
line diff
--- a/configure.in	Tue Feb 24 18:58:40 2004 +0000
+++ b/configure.in	Tue Feb 24 19:22:22 2004 +0000
@@ -374,6 +374,7 @@
         else
             ARTSC_CFLAGS=`$ARTSCCONFIG --cflags`
             ARTSC_LIBS=`$ARTSCCONFIG --libs`
+            ARTSC_PREFIX=`$ARTSCCONFIG --arts-prefix`
             AC_MSG_CHECKING(for aRts development environment)
             audio_arts=no
             save_CFLAGS="$CFLAGS"
@@ -391,7 +392,7 @@
                 AC_ARG_ENABLE(arts-shared,
 [  --enable-arts-shared    dynamically load aRts audio support [default=yes]],
                               , enable_arts_shared=yes)
-                arts_lib_spec=`echo $ARTSC_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libartsc.so.*/'`
+                arts_lib_spec="$ARTSC_PREFIX/lib/libartsc.so.*"
                 arts_lib=`ls $arts_lib_spec | head -1 | sed 's/.*\/\(.*\)/\1/'`
                 echo "-- $arts_lib_spec -> $arts_lib"
                 if test x$use_dlopen != xyes && \