diff configure.in @ 1341:d02b552e5304

Configure dynamically generates SDL_config.h I'm still wrestling with autoheader, but this should work for now... Fixed lots of build problems with C library support disabled
author Sam Lantinga <slouken@libsdl.org>
date Tue, 07 Feb 2006 12:11:33 +0000
parents 450721ad5436
children 905dc98a40fa
line wrap: on
line diff
--- a/configure.in	Tue Feb 07 11:18:21 2006 +0000
+++ b/configure.in	Tue Feb 07 12:11:33 2006 +0000
@@ -1,5 +1,42 @@
 dnl Process this file with autoconf to produce a configure script.
 AC_INIT(README)
+AH_TOP([/*
+    SDL - Simple DirectMedia Layer
+    Copyright (C) 1997-2006 Sam Lantinga
+
+    This library is free software; you can redistribute it and/or
+    modify it under the terms of the GNU Lesser General Public
+    License as published by the Free Software Foundation; either
+    version 2.1 of the License, or (at your option) any later version.
+
+    This library is distributed in the hope that it will be useful,
+    but WITHOUT ANY WARRANTY; without even the implied warranty of
+    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+    Lesser General Public License for more details.
+
+    You should have received a copy of the GNU Lesser General Public
+    License along with this library; if not, write to the Free Software
+    Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
+
+    Sam Lantinga
+    slouken@libsdl.org
+*/
+
+#ifndef _SDL_config_h
+#define _SDL_config_h
+
+/* This is a set of defines to configure the SDL features */
+
+/* Comment this if you want to build without any libc requirements */
+#undef HAVE_LIBC
+#ifdef HAVE_LIBC
+])
+AC_CONFIG_HEADER(include/SDL_config.h)
+AH_BOTTOM([
+#endif /* HAVE_LIBC */
+
+#endif /* _SDL_config_h */
+])
 
 dnl Set various version strings - taken gratefully from the GTk sources
 #
@@ -113,6 +150,40 @@
     fi
 fi
 
+dnl See whether we are allowed to use the system C library
+AC_ARG_ENABLE(libc,
+[  --enable-libc           Use the system C library [default=yes]],
+              , AC_DEFINE(HAVE_LIBC))
+
+dnl Checks for header files.
+AC_CHECK_HEADERS(alloca.h stdint.h stdlib.h stdarg.h malloc.h)
+AC_CHECK_HEADERS(ctype.h)
+AC_CHECK_HEADERS(string.h)
+AC_CHECK_HEADERS(stdio.h)
+AC_CHECK_HEADERS(signal.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_C_INLINE
+AC_TYPE_SIZE_T
+AC_CHECK_SIZEOF(char, 1)
+AC_CHECK_SIZEOF(short, 2)
+AC_CHECK_SIZEOF(int, 4)
+AC_CHECK_SIZEOF(long, 4)
+AC_CHECK_SIZEOF(long long, 8)
+
+dnl Checks for library functions.
+AC_FUNC_ALLOCA
+AC_CHECK_FUNCS(malloc calloc realloc free)
+AC_CHECK_FUNCS(getenv putenv qsort abs)
+AC_CHECK_FUNCS(memset memcpy memmove memcmp)
+AC_CHECK_FUNCS(strlen strcpy strncpy strcat strncat strdup)
+AC_CHECK_FUNCS(_strrev _strupr _strlwr)
+AC_CHECK_FUNCS(strchr strrchr strstr)
+AC_CHECK_FUNCS(itoa _ltoa _uitoa _ultoa strtol _i64toa _ui64toa strtoll atoi atof)
+AC_CHECK_FUNCS(strcmp strncmp stricmp strcasecmp)
+AC_CHECK_FUNCS(sscanf snprintf vsnprintf)
+
 dnl Initialize the compiler and linker flags for SDL applications
 
 SDL_CFLAGS=""