diff configure.in @ 4109:cd2ab40f1219 SDL-1.2

Made the mprotect() fix for SDL_SoftStretch() more general for hardened linux, etc.
author Sam Lantinga <slouken@libsdl.org>
date Sat, 29 Dec 2007 05:18:33 +0000
parents 4867f7f7dd34
children 0c3559059d6d
line wrap: on
line diff
--- a/configure.in	Sat Dec 29 03:50:29 2007 +0000
+++ b/configure.in	Sat Dec 29 05:18:33 2007 +0000
@@ -16,9 +16,9 @@
 #
 SDL_MAJOR_VERSION=1
 SDL_MINOR_VERSION=2
-SDL_MICRO_VERSION=12
-SDL_INTERFACE_AGE=1
-SDL_BINARY_AGE=12
+SDL_MICRO_VERSION=13
+SDL_INTERFACE_AGE=2
+SDL_BINARY_AGE=13
 SDL_VERSION=$SDL_MAJOR_VERSION.$SDL_MINOR_VERSION.$SDL_MICRO_VERSION
 
 AC_SUBST(SDL_MAJOR_VERSION)
@@ -146,7 +146,7 @@
     if test x$ac_cv_func_strtod = xyes; then
         AC_DEFINE(HAVE_STRTOD)
     fi
-    AC_CHECK_FUNCS(malloc calloc realloc free getenv putenv unsetenv qsort abs bcopy memset memcpy memmove strlen strlcpy strlcat strdup _strrev _strupr _strlwr strchr strrchr strstr itoa _ltoa _uitoa _ultoa strtol strtoul _i64toa _ui64toa strtoll strtoull atoi atof strcmp strncmp _stricmp strcasecmp _strnicmp strncasecmp sscanf snprintf vsnprintf iconv sigaction setjmp nanosleep)
+    AC_CHECK_FUNCS(malloc calloc realloc free getenv putenv unsetenv qsort abs bcopy memset memcpy memmove strlen strlcpy strlcat strdup _strrev _strupr _strlwr strchr strrchr strstr itoa _ltoa _uitoa _ultoa strtol strtoul _i64toa _ui64toa strtoll strtoull atoi atof strcmp strncmp _stricmp strcasecmp _strnicmp strncasecmp sscanf snprintf vsnprintf iconv sigaction setjmp nanosleep mprotect)
 
     AC_CHECK_LIB(iconv, libiconv_open, [EXTRA_LDFLAGS="$EXTRA_LDFLAGS -liconv"])
     AC_CHECK_LIB(m, pow, [EXTRA_LDFLAGS="$EXTRA_LDFLAGS -lm"])