diff configure.in @ 167:cb384ef627f6

Added support for DirectFB video on Linux (thanks Denis!)
author Sam Lantinga <slouken@libsdl.org>
date Tue, 04 Sep 2001 22:53:46 +0000
parents 39877400bd1e
children e92aa316c517
line wrap: on
line diff
--- a/configure.in	Tue Sep 04 22:48:09 2001 +0000
+++ b/configure.in	Tue Sep 04 22:53:46 2001 +0000
@@ -695,6 +695,46 @@
     fi
 }
 
+dnl Find DirectFB
+CheckDirectFB()
+{
+    AC_ARG_ENABLE(video-directfb,
+[  --enable-video-directfb    use DirectFB video driver [default=yes]],
+                  , enable_video_directfb=yes)
+    if test x$enable_video = xyes -a x$enable_video_directfb = xyes; then
+        video_directfb=no
+
+        AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+        if test x$PKG_CONFIG = xno ; then
+            AC_MSG_WARN([*** pkg-config is required to build the DirectFB video driver.])
+        else
+            AC_MSG_CHECKING(for DirectFB support)
+
+            if ! pkg-config --atleast-pkgconfig-version 0.5 ; then
+                AC_MSG_ERROR([*** pkg-config too old; version 0.5 or better required.])
+            fi
+
+            DIRECTFB_REQUIRED_VERSION=0.9.5
+
+            if $PKG_CONFIG --atleast-version $DIRECTFB_REQUIRED_VERSION directfb ; then
+                DIRECTFB_CFLAGS=`$PKG_CONFIG --cflags directfb`
+                DIRECTFB_LIBS=`$PKG_CONFIG --libs directfb`
+                video_directfb=yes
+            fi
+        fi
+
+        AC_MSG_RESULT($video_directfb)
+        if test x$video_directfb = xyes; then
+            CFLAGS="$CFLAGS -DENABLE_DIRECTFB"
+            VIDEO_SUBDIRS="$VIDEO_SUBDIRS directfb"
+            VIDEO_DRIVERS="$VIDEO_DRIVERS directfb/libvideo_directfb.la"
+
+            AC_SUBST(DIRECTFB_CFLAGS)
+            AC_SUBST(DIRECTFB_LIBS)
+        fi
+    fi
+}
+
 dnl See if we're running on PlayStation 2 hardware
 CheckPS2GS()
 {
@@ -1219,6 +1259,7 @@
         CheckNANOX
         CheckDGA
         CheckFBCON
+        CheckDirectFB
         CheckPS2GS
         CheckGGI
         CheckSVGA
@@ -2174,6 +2215,7 @@
 src/video/dga/Makefile
 src/video/nanox/Makefile
 src/video/fbcon/Makefile
+src/video/directfb/Makefile
 src/video/ps2gs/Makefile
 src/video/ggi/Makefile
 src/video/maccommon/Makefile