diff configure.in @ 1242:caf0328c8058

Add XME hooks to X11 driver instead of relying on libxme...libxme hasn't changed in five years, and it's a small .c file that just calls into the X11 dependencies we already use elsewhere. Including it directly allows us to make use of the dynamic X11 code. Fixes Bugzilla #41. --ryan.
author Ryan C. Gordon <icculus@icculus.org>
date Thu, 12 Jan 2006 22:46:36 +0000
parents 09c1408645df
children 08c730212ca2
line wrap: on
line diff
--- a/configure.in	Tue Jan 10 20:52:35 2006 +0000
+++ b/configure.in	Thu Jan 12 22:46:36 2006 +0000
@@ -760,19 +760,11 @@
                             , enable_video_x11_xme=yes)
             if test x$enable_video_x11_xme = xyes; then
                 AC_MSG_CHECKING(for Xi Graphics XiGMiscExtension support)
-                video_x11_xme=no
-                AC_TRY_COMPILE([
-                 #include <X11/Xlib.h>
-                 #include <X11/extensions/xme.h>
-                ],[
-                 XiGMiscResolutionInfo *resolutions;
-                ],[
                 video_x11_xme=yes
-                ])
                 AC_MSG_RESULT($video_x11_xme)
                 if test x$video_x11_xme = xyes; then
                     CFLAGS="$CFLAGS -DHAVE_XIGXME"
-                    SYSTEM_LIBS="$SYSTEM_LIBS -lxme"
+                    SYSTEM_LIBS="$SYSTEM_LIBS"
                 fi
             fi
         fi