diff configure.in @ 2040:be848c07f0b9

Fixed bug #321 Hi, if "configure" is given an explicit --libdir, the sdl-config still contains the default "${exec_prefix}/lib" for runtime linker path. That should be changed to $libdir, as this is where the library goes to... Regards, Juergen
author Sam Lantinga <slouken@libsdl.org>
date Sun, 24 Sep 2006 00:44:45 +0000
parents 4ddfbe55e105
children 5f6550e5184f da2ea0694d11
line wrap: on
line diff
--- a/configure.in	Sun Sep 24 00:36:49 2006 +0000
+++ b/configure.in	Sun Sep 24 00:44:45 2006 +0000
@@ -2452,10 +2452,10 @@
 
 if test "x$enable_rpath" = "xyes"; then
   if test $ARCH = bsdi -o $ARCH = freebsd -o $ARCH = irix -o $ARCH = linux -o $ARCH = netbsd; then
-    SDL_RLD_FLAGS="-Wl,-rpath,\${exec_prefix}/lib"
+    SDL_RLD_FLAGS="-Wl,-rpath,\${libdir}"
   fi
   if test $ARCH = solaris; then
-    SDL_RLD_FLAGS="-R\${exec_prefix}/lib"
+    SDL_RLD_FLAGS="-R\${libdir}"
   fi
 else
   SDL_RLD_FLAGS=""
@@ -2464,7 +2464,7 @@
 case "$ARCH" in
   macosx)
     # Evil hack to allow static linking on Mac OS X
-    SDL_STATIC_LIBS="\${exec_prefix}/lib/libSDL.a $EXTRA_LDFLAGS"
+    SDL_STATIC_LIBS="\${libdir}/libSDL.a $EXTRA_LDFLAGS"
     ;;
   *)
     SDL_STATIC_LIBS="$SDL_LIBS"