diff configure.in @ 2148:b93d0b4625f6

I'm not sure this is a good idea yet, since it adds a unicows.dll redistribution requirement on windows, but adding unicows allows SDL 1.3 to run on Windows 98.
author Sam Lantinga <slouken@libsdl.org>
date Thu, 05 Jul 2007 05:28:08 +0000
parents c2a276a27381
children eff395617ed8
line wrap: on
line diff
--- a/configure.in	Thu Jul 05 04:34:48 2007 +0000
+++ b/configure.in	Thu Jul 05 05:28:08 2007 +0000
@@ -2172,7 +2172,7 @@
         ARCH=win32
         if test "$build" != "$host"; then # cross-compiling
             # Default cross-compile location
-            ac_default_prefix=/usr/local/cross-tools/i386-mingw32msvc
+            ac_default_prefix=/usr/local/cross-tools/i386-mingw32
         else
             # Look for the location of the tools and install there
             if test "$BUILD_PREFIX" != ""; then
@@ -2253,7 +2253,7 @@
             have_loadso=yes
         fi
         # Set up the system libraries we need
-        EXTRA_LDFLAGS="$EXTRA_LDFLAGS -luser32 -lgdi32 -lmsimg32 -lwinmm"
+        EXTRA_LDFLAGS="$EXTRA_LDFLAGS -lunicows -luser32 -lgdi32 -lmsimg32 -lwinmm"
         # The Win32 platform requires special setup
         SDLMAIN_SOURCES="$srcdir/src/main/win32/*.c"
         SDL_CFLAGS="$SDL_CFLAGS -Dmain=SDL_main"