diff configure.in @ 1140:af8b0f9ac2f4

iPod Linux framebuffer support. --ryan. Date: Sun, 19 Jun 2005 15:53:22 -0700 From: Joshua Oreman <oremanj@gmail.com> To: sdl@libsdl.org Subject: [SDL] [PATCH] iPod framebuffer video driver Hi SDL-list, I've been working on a port of SDL to iPodLinux (http://www.ipodlinux.org). I've created a patch for both the standard 2-bit iPod screen (using an unchangeable palette) and the 16-bit iPod photo. The patch is attached, against version 1.2.8. I've created two pages on the iPodLinux wiki about this patch: http://www.ipodlinux.org/Building_SDL and http://www.ipodlinux.org/SDL_Programming. See those pages if you're curious. Comments? Questions? Is this something that might be able to get into SDL 1.2.9? Thanks for your feedback! -- Josh
author Ryan C. Gordon <icculus@icculus.org>
date Thu, 08 Sep 2005 07:33:22 +0000
parents d16c010d5d98
children 2651158f59b8
line wrap: on
line diff
--- a/configure.in	Thu Sep 08 07:20:59 2005 +0000
+++ b/configure.in	Thu Sep 08 07:33:22 2005 +0000
@@ -549,6 +549,20 @@
     fi
 }
 
+dnl Do the iPod thing
+CheckIPod()
+{
+    AC_ARG_ENABLE(ipod,
+[  --enable-ipod          configure SDL to work with iPodLinux [default=yes on arm-elf]],
+	, enable_ipod=yes)
+
+    if test x$enable_ipod = xyes; then
+	CFLAGS="$CFLAGS -DENABLE_IPOD -DIPOD"
+	VIDEO_SUBDIRS="$VIDEO_SUBDIRS ipod"
+	VIDEO_DRIVERS="$VIDEO_DRIVERS ipod/libvideo_ipod.la"
+    fi
+}	
+
 dnl Find the nanox include and library directories
 CheckNANOX()
 {
@@ -1306,7 +1320,7 @@
             pthread_lib="-lpthread"
             ;;
     esac
-    if test x$enable_threads = xyes -a x$enable_pthreads = xyes; then
+    if test x$enable_threads = xyes -a x$enable_pthreads = xyes -a x$enable_ipod != xyes; then
         # Save the original compiler flags and libraries
         ac_save_cflags="$CFLAGS"; ac_save_libs="$LIBS"
         # Add the pthread compiler flags and libraries
@@ -1932,6 +1946,15 @@
 }
 
 case "$target" in
+    arm-*-elf*)
+	ARCH=linux
+	CheckDummyVideo
+	CheckIPod
+	# Set up files for the timer library
+        if test x$enable_timers = xyes; then
+            COPY_ARCH_SRC(src/timer, linux, SDL_systimer.c)
+        fi
+	;;
     *-*-linux*|*-*-gnu*|*-*-k*bsd*-gnu)
         case "$target" in
           *-*-linux*) ARCH=linux ;;
@@ -2810,6 +2833,7 @@
 AM_CONDITIONAL(TARGET_MACOSX, test $ARCH = macosx)
 AM_CONDITIONAL(TARGET_QNX, test $ARCH = qnx)
 AM_CONDITIONAL(TARGET_MINT, test $ARCH = mint)
+AM_CONDITIONAL(TARGET_IPOD, test x$enable_ipod = xyes)
 
 # More automake conditionals
 AM_CONDITIONAL(USE_DIRECTX, test x$use_directx = xyes)
@@ -2989,6 +3013,7 @@
 src/video/fbcon/Makefile
 src/video/gem/Makefile
 src/video/ggi/Makefile
+src/video/ipod/Makefile
 src/video/maccommon/Makefile
 src/video/macdsp/Makefile
 src/video/macrom/Makefile