diff configure.in @ 1742:af4352da64d8

Fixed bug #206, fatbuild.sh works flawlessly on Intel Macs
author Sam Lantinga <slouken@libsdl.org>
date Fri, 28 Apr 2006 05:38:06 +0000
parents 9f59d4c5aaea
children 741dc4e89f3a
line wrap: on
line diff
--- a/configure.in	Thu Apr 27 11:18:03 2006 +0000
+++ b/configure.in	Fri Apr 28 05:38:06 2006 +0000
@@ -52,6 +52,11 @@
 dnl Set up the compiler and linker flags
 INCLUDE="-I$srcdir/include"
 if test x$srcdir != x.; then
+    # Remove SDL_config.h from the source directory, since it's the
+    # default one, and we want to include the one that we generate.
+    if test -f $srcdir/include/SDL_config.h; then
+        rm $srcdir/include/SDL_config.h
+    fi
     INCLUDE="-Iinclude $INCLUDE"
 fi
 case "$host" in
@@ -2332,6 +2337,7 @@
         # use here or in sdl-config. Hence we reset it.
         EXTRA_LDFLAGS=""
 
+        CheckVisibilityHidden
         CheckDummyVideo
         CheckDiskAudio
         CheckDummyAudio