diff configure.in @ 68:ac6645260d31

Added an audio driver that writes to disk (thanks Ryan!)
author Sam Lantinga <slouken@lokigames.com>
date Sat, 16 Jun 2001 01:51:42 +0000
parents 25dfe480c75e
children f590dd383b5d
line wrap: on
line diff
--- a/configure.in	Sat Jun 16 01:32:09 2001 +0000
+++ b/configure.in	Sat Jun 16 01:51:42 2001 +0000
@@ -368,6 +368,21 @@
     fi
 }
 
+
+dnl rcg07142001 See if the user wants the disk writer audio driver...
+CheckDiskAudio()
+{
+    AC_ARG_ENABLE(diskaudio,
+[  --enable-diskaudio  	  support the disk writer audio driver [default=no]],
+                  , enable_diskaudio=no)
+    if test x$enable_audio = xyes -a x$enable_diskaudio = xyes; then
+        CFLAGS="$CFLAGS -DDISKAUD_SUPPORT"
+        AUDIO_SUBDIRS="$AUDIO_SUBDIRS disk"
+        AUDIO_DRIVERS="$AUDIO_DRIVERS disk/libaudio_disk.la"
+    fi
+}
+
+
 dnl See if we can use x86 assembly blitters
 CheckNASM()
 {
@@ -1085,6 +1100,7 @@
     *-*-linux*)
         ARCH=linux
         CheckDummyVideo
+        CheckDiskAudio
         CheckNASM
         CheckOSS
         CheckALSA
@@ -1151,6 +1167,7 @@
     *-*-bsdi*)
         ARCH=bsdi
         CheckDummyVideo
+        CheckDiskAudio
         CheckNASM
         CheckOSS
         CheckARTSC
@@ -1194,6 +1211,7 @@
     *-*-freebsd*)
         ARCH=freebsd
         CheckDummyVideo
+        CheckDiskAudio
         CheckNASM
         CheckOSS
         CheckARTSC
@@ -1246,6 +1264,7 @@
     *-*-netbsd*)
         ARCH=netbsd
         CheckDummyVideo
+        CheckDiskAudio
         CheckNASM
         CheckOSS
         CheckARTSC
@@ -1297,6 +1316,7 @@
     *-*-openbsd*)
         ARCH=openbsd
         CheckDummyVideo
+        CheckDiskAudio
         CheckNASM
         CheckOSS
         CheckARTSC
@@ -1345,6 +1365,7 @@
     *-*-sysv5*)
         ARCH=sysv5
         CheckDummyVideo
+        CheckDiskAudio
         CheckNASM
         CheckOSS
         CheckARTSC
@@ -1392,6 +1413,7 @@
         ARCH=solaris
         CFLAGS="$CFLAGS -D__ELF__" # Fix for nasm on Solaris x86
         CheckDummyVideo
+        CheckDiskAudio
         CheckNASM
         CheckOSS
         CheckARTSC
@@ -1438,6 +1460,7 @@
     *-*-irix*)
         ARCH=irix
         CheckDummyVideo
+        CheckDiskAudio
         CheckNAS
         CheckX11
         CheckAAlib
@@ -1496,6 +1519,7 @@
     *-*-hpux*)
         ARCH=hpux
         CheckDummyVideo
+        CheckDiskAudio
         CheckOSS
         CheckNAS
         CheckX11
@@ -1540,6 +1564,7 @@
     *-*-aix*)
         ARCH=aix
         CheckDummyVideo
+        CheckDiskAudio
         CheckOSS
         CheckNAS
         CheckX11
@@ -1583,6 +1608,7 @@
     *-*-osf*)
         ARCH=osf
         CheckDummyVideo
+        CheckDiskAudio
         CheckNAS
         CheckX11
         CheckGGI
@@ -1626,6 +1652,7 @@
     *-*-qnx*)
         ARCH=qnx
         CheckDummyVideo
+        CheckDiskAudio
         CheckNAS
         CheckPHOTON
         CheckX11
@@ -1680,6 +1707,7 @@
             fi
         fi
         CheckDummyVideo
+        CheckDiskAudio
         CheckWIN32
         CheckDIRECTX
         CheckNASM
@@ -1736,6 +1764,7 @@
         ARCH=beos
         ac_default_prefix=/boot/develop/tools/gnupro
         CheckDummyVideo
+        CheckDiskAudio
         CheckNASM
         CheckBWINDOW
         CheckBeGL
@@ -1781,6 +1810,7 @@
         # for which this case would be handy.
         ARCH=macos
         CheckDummyVideo
+        CheckDiskAudio
         CheckTOOLBOX
         CheckMacGL
         # Set up files for the main() stub
@@ -1824,6 +1854,7 @@
         # config.guess comes back with "darwin", so go with the flow.
         ARCH=macos
         CheckDummyVideo
+        CheckDiskAudio
         CheckCARBON
         CheckMacGL
         CheckPTHREAD
@@ -1973,6 +2004,7 @@
 src/audio/ums/Makefile
 src/audio/windib/Makefile
 src/audio/windx5/Makefile
+src/audio/disk/Makefile
 src/video/Makefile
 src/video/cybergfx/Makefile
 src/video/x11/Makefile