diff configure.in @ 948:ac488ad4ef1d

Don't fail if we don't have ALSA available
author Sam Lantinga <slouken@libsdl.org>
date Tue, 24 Aug 2004 06:32:50 +0000
parents c7c04f811994
children d74fbf56f2f6
line wrap: on
line diff
--- a/configure.in	Sat Aug 21 20:35:50 2004 +0000
+++ b/configure.in	Tue Aug 24 06:32:50 2004 +0000
@@ -282,8 +282,7 @@
 [  --enable-alsa           support the ALSA audio API [default=yes]],
                   , enable_alsa=yes)
     if test x$enable_audio = xyes -a x$enable_alsa = xyes; then
-        have_alsa=no
-        AM_PATH_ALSA(0.9.0, have_alsa=yes)
+        AM_PATH_ALSA(0.9.0, have_alsa=yes, have_alsa=no)
         if test x$have_alsa = xyes; then
             AC_ARG_ENABLE(alsa-shared,
 [  --enable-alsa-shared     dynamically load ALSA audio support [default=yes]],
@@ -364,9 +363,8 @@
 [  --enable-esd            support the Enlightened Sound Daemon [default=yes]],
                   , enable_esd=yes)
     if test x$enable_audio = xyes -a x$enable_esd = xyes; then
-        use_esd=no
-        AM_PATH_ESD(0.2.8, use_esd=yes)
-        if test x$use_esd = xyes; then
+        AM_PATH_ESD(0.2.8, have_esd=yes, have_esd=no)
+        if test x$have_esd = xyes; then
             AC_ARG_ENABLE(esd-shared,
 [  --enable-esd-shared     dynamically load ESD audio support [default=yes]],
                           , enable_esd_shared=yes)