diff configure.in @ 1035:974ba6ae0fa3

Date: Wed, 26 Jan 2005 13:37:09 GMT From: Peter Naulls Subject: RISC OS SDL Patches Sam, I've attached a diff of the latest changes to libSDL for RISC OS support. These changes are by Alan Buckley and myself. The most significant of these are: Optimised assembler blit rountines - I've attached the file src/video/riscos/SDL_riscosASM.s which is needed for this. Move to using /dev/dsp instead of its own audio implementation. This means that src/audio/riscos/SDL_drenderer.c should be removed Typo fixes. Mainly correct spelling of "RISC OS", but some from elsewhere too.
author Sam Lantinga <slouken@libsdl.org>
date Sat, 12 Feb 2005 18:01:31 +0000
parents cca9aeb2934f
children ffaaf7ecf685
line wrap: on
line diff
--- a/configure.in	Sat Jan 29 09:58:40 2005 +0000
+++ b/configure.in	Sat Feb 12 18:01:31 2005 +0000
@@ -2644,7 +2644,7 @@
         # MiNT does not define "unix"
         CFLAGS="$CFLAGS -Dunix"
         ;;
-    *-*-riscos)
+    *-riscos)
         ARCH=riscos
         # Set up files for the video library
         if test x$enable_video = xyes; then
@@ -2653,8 +2653,11 @@
         fi
         # Set up files for the audio library
         if test x$enable_audio = xyes; then
-            AUDIO_SUBDIRS="$AUDIO_SUBDIRS riscos"
-            AUDIO_DRIVERS="$AUDIO_DRIVERS riscos/libaudio_riscos.la"
+            CFLAGS="$CFLAGS -DOSS_SUPPORT"
+            AUDIO_SUBDIRS="$AUDIO_SUBDIRS dsp"
+            AUDIO_DRIVERS="$AUDIO_DRIVERS dsp/libaudio_dsp.la"
+            AUDIO_SUBDIRS="$AUDIO_SUBDIRS dma"
+            AUDIO_DRIVERS="$AUDIO_DRIVERS dma/libaudio_dma.la"
         fi
         # Set up files for the joystick library
         if test x$enable_joystick = xyes; then
@@ -2684,7 +2687,7 @@
             COPY_ARCH_SRC(src/timer, riscos, SDL_systimer.c)
         fi
 
-        CFLAGS="$CFLAGS -DENABLE_RISCOS -DDRENDERER_SUPPORT"
+        CFLAGS="$CFLAGS -DENABLE_RISCOS"
 
         SYSTEM_LIBS="$SYSTEM_LIBS -ljpeg -ltiff -lpng -lz"
         ;;
@@ -2859,7 +2862,6 @@
 src/audio/nto/Makefile
 src/audio/openbsd/Makefile
 src/audio/paudio/Makefile
-src/audio/riscos/Makefile
 src/audio/sun/Makefile
 src/audio/ums/Makefile
 src/audio/windib/Makefile