diff src/audio/alsa/Makefile.am @ 865:92615154bb68

Date: Sun, 29 Feb 2004 15:14:22 +0200 From: Martin_Storsj Subject: Dynamic loading of ALSA I recently discovered that SDL can dynamically load ESD and aRts, and made a patch which adds this same functionality to ALSA. The update for configure.in isn't too good (it should e.g. look for libasound.so in other directories than /usr/lib), because I'm not too good at shellscripting and autoconf. The reason for using dlfcn.h and dlopen instead of SDL_LoadLibrary and SDL_LoadFunction is that libasound uses versioned symbols, and it is necessary to load the correct version using dlvsym. This isn't probably any real portability issue, because ALSA is linux-only.
author Sam Lantinga <slouken@libsdl.org>
date Tue, 02 Mar 2004 12:49:16 +0000
parents 74212992fb08
children
line wrap: on
line diff
--- a/src/audio/alsa/Makefile.am	Tue Mar 02 12:45:22 2004 +0000
+++ b/src/audio/alsa/Makefile.am	Tue Mar 02 12:49:16 2004 +0000
@@ -4,6 +4,8 @@
 noinst_LTLIBRARIES = libaudio_alsa.la
 libaudio_alsa_la_SOURCES = $(SRCS)
 
+alsa_lib = \"@alsa_lib@\"
+
 # The SDL audio driver sources
 SRCS =	SDL_alsa_audio.c	\
 	SDL_alsa_audio.h