diff configure.in @ 2643:91fd5d3cb90e gsoc2008_force_feedback

Made LINUXEV required for haptic.
author Edgar Simo <bobbens@gmail.com>
date Tue, 12 Aug 2008 20:46:39 +0000
parents d551e29f086b
children 6d705ec89fb6
line wrap: on
line diff
--- a/configure.in	Mon Aug 11 15:29:28 2008 +0000
+++ b/configure.in	Tue Aug 12 20:46:39 2008 +0000
@@ -2186,13 +2186,15 @@
         fi
         # Set up files for the haptic library
         if test x$enable_haptic = xyes; then
-          case $ARCH in
-            linux)
-                AC_DEFINE(SDL_HAPTIC_LINUX)
-                SOURCES="$SOURCES $srcdir/src/haptic/linux/*.c"
-                have_haptic=yes
-            ;;
-          esac
+           if test x$use_input_events = xyes; then
+             case $ARCH in
+               linux)
+                   AC_DEFINE(SDL_HAPTIC_LINUX)
+                   SOURCES="$SOURCES $srcdir/src/haptic/linux/*.c"
+                   have_haptic=yes
+               ;;
+             esac
+           fi
         fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then