diff configure.in @ 687:91400ecf307d

Date: Mon, 11 Aug 2003 22:49:06 +0100 From: Peter Naulls Subject: RISC OS patches This patch includes a patch to configure.in for RISC OS cross compiling which was somehow missed from last time. It also corrects BPP setting and checking behaviour.
author Sam Lantinga <slouken@libsdl.org>
date Mon, 11 Aug 2003 22:28:13 +0000
parents 9dcfc694a1e4
children b87d8d4c205d
line wrap: on
line diff
--- a/configure.in	Sun Aug 10 17:49:51 2003 +0000
+++ b/configure.in	Mon Aug 11 22:28:13 2003 +0000
@@ -2489,6 +2489,26 @@
         # MiNT does not define "unix"
         CFLAGS="$CFLAGS -Dunix"
         ;;
+    *-*-riscos)
+        ARCH=riscos
+        JOYSTICK_SUBDIRS="$JOYSTICK_SUBDIRS riscos"
+        JOYSTICK_DRIVERS="$JOYSTICK_DRIVERS riscos/libjoystick_riscos.la"
+        COPY_ARCH_SRC(src/timer, riscos, SDL_systimer.c)
+        COPY_ARCH_SRC(src/main, linux, SDL_main.c)
+        VIDEO_SUBDIRS="$VIDEO_SUBDIRS riscos"
+        VIDEO_DRIVERS="$VIDEO_DRIVERS riscos/libvideo_riscos.la"
+        AUDIO_SUBDIRS="$AUDIO_SUBDIRS riscos"
+        AUDIO_DRIVERS="$AUDIO_DRIVERS riscos/libaudio_riscos.la"
+
+        if test x$enable_cdrom = xyes; then
+            CDROM_SUBDIRS="$CDROM_SUBDIRS dummy"
+            CDROM_DRIVERS="$CDROM_DRIVERS dummy/libcdrom_dummy.la"
+        fi
+
+        CFLAGS="$CFLAGS -DDISABLE_THREADS -DENABLE_RISCOS -DDRENDERER_SUPPORT"
+
+        SYSTEM_LIBS="$SYSTEM_LIBS -ljpeg -ltiff -lpng -lz"
+        ;;
     *)
         AC_MSG_ERROR(Unsupported target:  Please add to configure.in)
         ;;