diff configure.in @ 3917:8a3a0f1179f3 SDL-1.2

Patched fbcon to compile on newer Linux kernels that don't #define PAGE_SIZE, since a memory page's size may vary on various architectures and kernel configurations. Will use getpagesize() if it exists, the PAGE_SIZE #define from older kernels if that doesn't, and #error out if that's not there either...but it's probably 4096 in that case. We may revisit this. Fixes Bugzilla #392.
author Ryan C. Gordon <icculus@icculus.org>
date Thu, 15 Feb 2007 23:50:45 +0000
parents 3a7248359cdd
children 3b5c90889156
line wrap: on
line diff
--- a/configure.in	Thu Feb 15 11:06:22 2007 +0000
+++ b/configure.in	Thu Feb 15 23:50:45 2007 +0000
@@ -1125,6 +1125,7 @@
         ])
         AC_MSG_RESULT($video_fbcon)
         if test x$video_fbcon = xyes; then
+            AC_CHECK_FUNCS(getpagesize)
             AC_DEFINE(SDL_VIDEO_DRIVER_FBCON)
             SOURCES="$SOURCES $srcdir/src/video/fbcon/*.c"
             have_video=yes