diff configure.in @ 873:89666943c598

Date: Sun, 07 Mar 2004 22:54:11 +0900 From: Hayashi Naoyuki Subject: Tru64 cdrom and pthread option fix SDL-1.2.7/src/cdrom/osf/SDL_syscdrom.c Fixes Some CD-ROM drives(ex. TEAC CD-532E) cannot play first 150 frames(aka gap). CheckDrive() fix. The end of comment is "* /" in AddDrive(). SDL-1.2.7/configure.in Fixes Add *-*-osf pthread option and delete line SDL_LIBS="$SDL_LIBS -lrt".
author Sam Lantinga <slouken@libsdl.org>
date Sun, 07 Mar 2004 16:40:15 +0000
parents e805075f6d94
children 20d3a599f601
line wrap: on
line diff
--- a/configure.in	Sat Mar 06 02:58:06 2004 +0000
+++ b/configure.in	Sun Mar 07 16:40:15 2004 +0000
@@ -1217,6 +1217,15 @@
             pthread_cflags=""
             pthread_lib=""
             ;;
+        *-*-osf*)
+            if test x$ac_cv_prog_gcc = xyes; then
+                pthread_cflags="-D_REENTRANT"
+                pthread_lib="-lpthread -lrt"
+            else
+                pthread_cflags="-pthread"
+                pthread_lib="-lpthread -lrt"
+            fi
+            ;;
         *)
             pthread_cflags="-D_REENTRANT"
             pthread_lib="-lpthread"
@@ -2268,7 +2277,6 @@
         CheckOpenGL
         CheckPTHREAD
         CheckSIGACTION
-        SDL_LIBS="$SDL_LIBS -lrt"
         # Set up files for the audio library
         if test x$enable_audio = xyes; then
             CFLAGS="$CFLAGS -I/usr/include/mme -DMMEAUDIO_SUPPORT"