diff configure.in @ 3268:82ce350be859

Removed outdated iPodLinux support
author Sam Lantinga <slouken@libsdl.org>
date Sat, 19 Sep 2009 06:24:07 +0000
parents 94fb40a4a9a7
children fb9b6b2924ba
line wrap: on
line diff
--- a/configure.in	Sat Sep 19 05:47:54 2009 +0000
+++ b/configure.in	Sat Sep 19 06:24:07 2009 +0000
@@ -943,20 +943,6 @@
 }
 
 
-dnl Do the iPod thing
-CheckIPod()
-{
-    AC_ARG_ENABLE(ipod,
-AC_HELP_STRING([--enable-ipod], [configure SDL to work with iPodLinux [default=yes on arm-elf]]),
-        , enable_ipod=yes)
-
-    if test x$enable_ipod = xyes; then
-        EXTRA_CFLAGS="$EXTRA_CFLAGS -DIPOD"
-        AC_DEFINE(SDL_VIDEO_DRIVER_IPOD)
-        SOURCES="$SOURCES $srcdir/src/video/ipod/*.c"
-    fi
-}
-
 dnl Find the nanox include and library directories
 CheckNANOX()
 {
@@ -2004,7 +1990,7 @@
             pthread_lib="-lpthread"
             ;;
     esac
-    if test x$enable_threads = xyes -a x$enable_pthreads = xyes -a x$enable_ipod != xyes; then
+    if test x$enable_threads = xyes -a x$enable_pthreads = xyes; then
         # Save the original compiler flags and libraries
         ac_save_cflags="$CFLAGS"; ac_save_libs="$LIBS"
         # Add the pthread compiler flags and libraries