diff configure.in @ 678:7f691fa4c1c7

Turn dynamic loading of esd and arts on by default Hmm, what to do about Objective C dependencies....
author Sam Lantinga <slouken@libsdl.org>
date Sat, 09 Aug 2003 20:36:29 +0000
parents 73506d26a1f4
children 34f03ca736b7
line wrap: on
line diff
--- a/configure.in	Sat Aug 09 18:27:27 2003 +0000
+++ b/configure.in	Sat Aug 09 20:36:29 2003 +0000
@@ -329,8 +329,8 @@
         AM_PATH_ESD(0.2.8, use_esd=yes)
         if test x$use_esd = xyes; then
             AC_ARG_ENABLE(esd-shared,
-[  --enable-esd-shared     dynamically load ESD audio support [default=no]],
-                          , enable_esd_shared=no)
+[  --enable-esd-shared     dynamically load ESD audio support [default=yes]],
+                          , enable_esd_shared=yes)
             esd_lib_spec=`echo $ESD_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libesd.so.*/'`
             esd_lib=`ls $esd_lib_spec | head -1 | sed 's/.*\/\(.*\)/\1/'`
             echo "-- $esd_lib_spec -> $esd_lib"
@@ -379,8 +379,8 @@
             AC_MSG_RESULT($audio_arts)
             if test x$audio_arts = xyes; then
                 AC_ARG_ENABLE(arts-shared,
-[  --enable-arts-shared    dynamically load aRts audio support [default=no]],
-                              , enable_arts_shared=no)
+[  --enable-arts-shared    dynamically load aRts audio support [default=yes]],
+                              , enable_arts_shared=yes)
                 arts_lib_spec=`echo $ARTSC_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libartsc.so.*/'`
                 arts_lib=`ls $arts_lib_spec | head -1 | sed 's/.*\/\(.*\)/\1/'`
                 echo "-- $arts_lib_spec -> $arts_lib"
@@ -775,8 +775,8 @@
 CheckDirectFB()
 {
     AC_ARG_ENABLE(video-directfb,
-[  --enable-video-directfb use DirectFB video driver [default=yes]],
-                  , enable_video_directfb=yes)
+[  --enable-video-directfb use DirectFB video driver [default=no]],
+                  , enable_video_directfb=no)
     if test x$enable_video = xyes -a x$enable_video_directfb = xyes; then
         video_directfb=no
 
@@ -2602,9 +2602,9 @@
         OBJCFLAGS="$CFLAGS"
         AC_SUBST(OBJCFLAGS)
         dnl _AM_DEPENDENCIES(OBJC) doesn't work, so hard code OBJCDEPMODE here
-        dnl _AM_DEPENDENCIES(OBJC)
-        OBJCDEPMODE="depmode=gcc3"
-        AC_SUBST(OBJCDEPMODE)
+        #OBJCDEPMODE="depmode=gcc3"
+        #AC_SUBST(OBJCDEPMODE)
+        _AM_DEPENDENCIES(OBJC)
         AC_MSG_RESULT(not implemented yet)
         ;;
 esac