diff configure.in @ 1625:7e89aa7843c5

Fixed bug #193 The attached patch is mostly cosmetic: Currently, we always add both -framework OpenGL and -framework AGL for Mac OS X command line builds. However, the former is only used for the Cocoa video driver, and the latter only for the Carbon video driver (as far as I can tell, at least). Hence the attached patch modifies configure.in so that each only gets added to the list of frameworks if the corresponding video driver is enabled.
author Sam Lantinga <slouken@libsdl.org>
date Thu, 13 Apr 2006 13:30:21 +0000
parents 8208ae96bb2d
children 10b4827452a8
line wrap: on
line diff
--- a/configure.in	Thu Apr 13 13:29:00 2006 +0000
+++ b/configure.in	Thu Apr 13 13:30:21 2006 +0000
@@ -1444,9 +1444,12 @@
         AC_DEFINE(SDL_VIDEO_OPENGL)
         case "$host" in
             *-*-darwin*)
-                EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,OpenGL"
-                # The following is probably not available in Darwin:
-                EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,AGL"
+                if test x$enable_video_cocoa = xyes; then
+                    EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,OpenGL"
+                fi
+                if test x$enable_video_carbon = xyes; then
+                    EXTRA_LDFLAGS="$EXTRA_LDFLAGS -Wl,-framework,AGL"
+                fi
         esac
     fi
 }