diff src/video/Makefile.am @ 0:74212992fb08

Initial revision
author Sam Lantinga <slouken@lokigames.com>
date Thu, 26 Apr 2001 16:45:43 +0000
parents
children cf2af46e9e2a
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/video/Makefile.am	Thu Apr 26 16:45:43 2001 +0000
@@ -0,0 +1,49 @@
+
+## Makefile.am for the SDL video library
+
+noinst_LTLIBRARIES = libvideo.la
+
+# Define which subdirectories need to be built
+SUBDIRS = @VIDEO_SUBDIRS@
+DIST_SUBDIRS = x11 dga fbcon svga ggi aalib \
+               wincommon windib windx5 \
+               maccommon macdsp macrom bwindow photon cybergfx
+
+DRIVERS = @VIDEO_DRIVERS@
+
+# Include the architecture-independent sources
+COMMON_SRCS =			\
+	SDL_RLEaccel.c		\
+	SDL_RLEaccel_c.h	\
+	SDL_blit.c		\
+	SDL_blit.h		\
+	SDL_blit_0.c		\
+	SDL_blit_1.c		\
+	SDL_blit_A.c		\
+	SDL_blit_A.h		\
+	SDL_blit_N.c		\
+	SDL_bmp.c		\
+	SDL_cursor.c		\
+	SDL_cursor_c.h		\
+	SDL_gamma.c		\
+	SDL_glfuncs.h		\
+	SDL_leaks.h		\
+	SDL_memops.h		\
+	SDL_pixels.c		\
+	SDL_pixels_c.h		\
+	SDL_surface.c		\
+	SDL_stretch.c		\
+	SDL_stretch_c.h		\
+	SDL_sysvideo.h		\
+	SDL_video.c		\
+	SDL_yuv.c		\
+	SDL_yuvfuncs.h		\
+	SDL_yuv_sw.c		\
+	SDL_yuv_sw_c.h		\
+	SDL_yuv_mmx.c		\
+	blank_cursor.h		\
+	default_cursor.h
+
+libvideo_la_SOURCES = $(COMMON_SRCS)
+libvideo_la_LIBADD = $(DRIVERS)
+libvideo_la_DEPENDENCIES = $(DRIVERS)