diff src/timer/Makefile.am @ 0:74212992fb08

Initial revision
author Sam Lantinga <slouken@lokigames.com>
date Thu, 26 Apr 2001 16:45:43 +0000
parents
children 69ee0b88b615
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/timer/Makefile.am	Thu Apr 26 16:45:43 2001 +0000
@@ -0,0 +1,27 @@
+
+## Makefile.am for the SDL timer library
+
+noinst_LTLIBRARIES = libtimer.la
+
+ARCH_SUBDIRS = amigaos beos linux macos win32
+
+# Include the architecture-independent sources
+COMMON_SRCS = SDL_timer.c SDL_timer_c.h SDL_systimer.h
+
+# Include the architecture-specific sources
+ARCH_SRCS = SDL_systimer.c
+
+libtimer_la_SOURCES = $(COMMON_SRCS) $(ARCH_SRCS)
+
+## Let automake know that it shouldn't distribute linked sources
+BUILT_SOURCES = $(ARCH_SRCS)
+
+## Let automake know that it should remove these for distribution
+DISTCLEANFILES = $(ARCH_SRCS)
+
+# The architecture specific directories need to be copied into place
+# when building a distribution.
+dist-hook:
+	(cd $(distdir) && rm -f $(BUILT_SOURCES))
+	cp -rp $(ARCH_SUBDIRS) $(distdir)
+	(cd $(distdir) && rm -rf `find . -name CVS`)