diff src/hermes/Makefile.am @ 0:74212992fb08

Initial revision
author Sam Lantinga <slouken@lokigames.com>
date Thu, 26 Apr 2001 16:45:43 +0000
parents
children 2d1753bc178a
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/hermes/Makefile.am	Thu Apr 26 16:45:43 2001 +0000
@@ -0,0 +1,33 @@
+###########################################################################
+#
+# Some consistent rules for building asm files:
+
+STRIP_FPIC = sh $(top_srcdir)/strip_fPIC.sh
+
+SUFFIXES = .asm
+
+.asm.lo:
+	$(LIBTOOL) --mode=compile $(STRIP_FPIC) $(NASM) @NASMFLAGS@ $<
+
+###########################################################################
+
+# The hermes library target
+noinst_LTLIBRARIES = libhermes.la
+
+libhermes_la_SOURCES = $(PORTABLE_SRCS)
+
+# The hermes library sources
+PORTABLE_SRCS = 		\
+	mmx_main.asm		\
+	mmxp2_32.asm		\
+	x86_main.asm		\
+	x86p_16.asm		\
+	x86p_32.asm		\
+	\
+	HeadMMX.h		\
+	HeadX86.h
+
+EXTRA_DIST =			\
+	COPYING.LIB		\
+	README
+