diff src/audio/Makefile.am @ 0:74212992fb08

Initial revision
author Sam Lantinga <slouken@lokigames.com>
date Thu, 26 Apr 2001 16:45:43 +0000
parents
children 3ad7157c6cfa
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/audio/Makefile.am	Thu Apr 26 16:45:43 2001 +0000
@@ -0,0 +1,29 @@
+
+## Makefile.am for the SDL audio library
+
+noinst_LTLIBRARIES = libaudio.la
+
+# Define which subdirectories need to be built
+SUBDIRS = @AUDIO_SUBDIRS@
+DIST_SUBDIRS = alsa arts baudio dma dmedia dsp esd macrom nas nto \
+               paudio sun ums windib windx5
+
+DRIVERS = @AUDIO_DRIVERS@
+
+# Include the architecture-independent sources
+COMMON_SRCS =			\
+	SDL_audio.c		\
+	SDL_audio_c.h		\
+	SDL_audiocvt.c		\
+	SDL_audiodev.c		\
+	SDL_audiodev_c.h	\
+	SDL_audiomem.c		\
+	SDL_audiomem.h		\
+	SDL_mixer.c		\
+	SDL_sysaudio.h		\
+	SDL_wave.c		\
+	SDL_wave.h
+
+libaudio_la_SOURCES = $(COMMON_SRCS)
+libaudio_la_LIBADD = $(DRIVERS)
+libaudio_la_DEPENDENCIES = $(DRIVERS)