diff configure.in @ 1201:718d00094f82

Date: Sat, 10 Dec 2005 18:29:41 +0100 From: Alberto Mardegan <mardy@users.sourceforge.net> To: sdl@libsdl.org Subject: [SDL] [PATCH] Touchscreen support to fbcon via tslib Hi all! I'm new to this list, I just subscribed. I've attached to this e-mail a patch I've written in order to add Touchscreen support to SDL's fbcon module via the tslib library. Since it introduces a new dependency, I've also edited the the configure.in file and added it as a compile-time option. This patch is especially useful for handhelds (I've tested it in my Zaurus). Please consider applying it. :-) -- Saluti, Mardy http://interlingua.altervista.org
author Ryan C. Gordon <icculus@icculus.org>
date Mon, 12 Dec 2005 09:26:32 +0000
parents 8f418dce02b2
children a67c8b2ae356
line wrap: on
line diff
--- a/configure.in	Mon Dec 12 09:22:36 2005 +0000
+++ b/configure.in	Mon Dec 12 09:26:32 2005 +0000
@@ -1233,6 +1233,29 @@
     fi
 }
 
+dnl See if we can use the Touchscreen input library
+CheckTslib()
+{
+    AC_ARG_ENABLE(input-tslib,
+[  --enable-input-tslib    use the Touchscreen library for input [default=yes]],
+                  , enable_input_tslib=yes)
+    if test x$enable_input_tslib = xyes; then
+        AC_MSG_CHECKING(for Touchscreen library support)
+        enable_input_tslib=no
+        AC_TRY_COMPILE([
+          #include "tslib.h"
+        ],[
+        ],[
+        enable_input_tslib=yes
+        ])
+        AC_MSG_RESULT($enable_input_tslib)
+        if test x$enable_input_tslib = xyes; then
+            CFLAGS="$CFLAGS -DHAVE_TSLIB"
+            SYSTEM_LIBS="$SYSTEM_LIBS -lts"
+        fi
+    fi
+}
+
 dnl See if we can use GNU pth library for threads
 CheckPTH()
 {
@@ -2078,6 +2101,7 @@
         CheckPicoGUI
         CheckOpenGLX11
         CheckInputEvents
+        CheckTslib
         CheckPTHREAD
         CheckSIGACTION
         CheckAltivec