diff configure.in @ 5231:710d00cb3a6a

Made it possible to disable the rendering subsystem with configure --disable-render
author Sam Lantinga <slouken@libsdl.org>
date Tue, 08 Feb 2011 10:04:09 -0800
parents 5d01d426f2ea
children 6a65c1fc07af
line wrap: on
line diff
--- a/configure.in	Mon Feb 07 22:57:33 2011 -0800
+++ b/configure.in	Tue Feb 08 10:04:09 2011 -0800
@@ -362,6 +362,12 @@
 if test x$enable_video != xyes; then
     AC_DEFINE(SDL_VIDEO_DISABLED)
 fi
+AC_ARG_ENABLE(render,
+AC_HELP_STRING([--enable-render], [Enable the render subsystem [[default=yes]]]),
+              , enable_render=yes)
+if test x$enable_render != xyes; then
+    AC_DEFINE(SDL_RENDER_DISABLED)
+fi
 AC_ARG_ENABLE(events,
 AC_HELP_STRING([--enable-events], [Enable the events subsystem [[default=yes]]]),
               , enable_events=yes)