diff configure.in @ 433:706de3956894

Added initial support for PicoGUI (thanks Micah!)
author Sam Lantinga <slouken@libsdl.org>
date Thu, 01 Aug 2002 23:24:13 +0000
parents 1338c24e30cb
children 3691cc3e14b3
line wrap: on
line diff
--- a/configure.in	Thu Aug 01 23:08:41 2002 +0000
+++ b/configure.in	Thu Aug 01 23:24:13 2002 +0000
@@ -1470,6 +1470,32 @@
     fi
 }
 
+dnl Set up the PicoGUI video driver if enabled
+CheckPicoGUI()
+{
+    AC_ARG_ENABLE(video-picogui,
+[  --enable-video-picogui  use PicoGUI video driver [default=no]],
+                  , enable_video_picogui=no)
+    if test x$enable_video = xyes -a x$enable_video_picogui = xyes; then
+        AC_MSG_CHECKING(for PicoGUI support)
+        video_picogui=no
+        AC_TRY_COMPILE([
+         #include <picogui.h>
+        ],[
+        ],[
+        video_picogui=yes
+        ])
+        AC_MSG_RESULT($video_picogui)
+        if test x$video_picogui = xyes; then
+	    SDL_LIBS="$SDL_LIBS -lpgui"
+            CFLAGS="$CFLAGS -DENABLE_PICOGUI"
+            VIDEO_SUBDIRS="$VIDEO_SUBDIRS picogui"
+            VIDEO_DRIVERS="$VIDEO_DRIVERS picogui/libvideo_picogui.la"
+        fi
+        AC_LANG_C
+    fi
+}
+
 dnl Set up the Mac toolbox video driver for Mac OS 7-9
 CheckTOOLBOX()
 {
@@ -1676,6 +1702,7 @@
         CheckSVGA
         CheckAAlib
         CheckQtopia
+        CheckPicoGUI
         CheckOpenGL
         CheckInputEvents
         CheckPTHREAD
@@ -2602,6 +2629,7 @@
 src/video/xbios/Makefile
 src/video/gem/Makefile
 src/video/qtopia/Makefile
+src/video/picogui/Makefile
 src/events/Makefile
 src/joystick/Makefile
 src/joystick/amigaos/Makefile