diff Makefile.am @ 138:69ee0b88b615

Applied Paul Jenner's patches to fix "make distcheck" and "make rpm"
author Sam Lantinga <slouken@libsdl.org>
date Thu, 09 Aug 2001 05:31:32 +0000
parents d49e9d023119
children e92aa316c517
line wrap: on
line diff
--- a/Makefile.am	Fri Aug 03 05:51:33 2001 +0000
+++ b/Makefile.am	Thu Aug 09 05:31:32 2001 +0000
@@ -36,6 +36,7 @@
         WhatsNew	\
         docs.html	\
         sdl.m4		\
+        SDL.spec	\
         autogen.sh	\
         strip_fPIC.sh
 
@@ -48,8 +49,7 @@
 
 # Rule to build RPM distribution package
 rpm: $(PACKAGE)-$(VERSION).tar.gz
-	cp $(PACKAGE)-$(VERSION).tar.gz /usr/src/redhat/SOURCES
-	rpm -ba SDL.spec
+	rpm -ta $(PACKAGE)-$(VERSION).tar.gz
 
 # Rule to rebuild the export lists for BeOS, MacOS and Win32.
 exports:
@@ -79,7 +79,7 @@
 # Grab the test programs for the distribution:
 dist-hook:
 	if test -f test/Makefile; then (cd test; make distclean); fi
-	cp -rp test $(distdir)
+	cp -rp $(srcdir)/test $(distdir)
 	rm -rf `find $(distdir) -type d -name CVS -print`
 
 # Create a CVS snapshot that people can run update -d on