diff configure.in @ 3168:6338b7f2d024

Hi, I have prepared a set of patches to readd WindowsCE support to SDL 1.3. I've created a new GAPI/Rawframebuffer and a DirectDraw renderer. Both renderers are work in progress and there are several unimplemented cases. (Notably RenderLine/RenderPoint/RenderFill/QueryTexturePixels/UpdateTexture and texture blending ) Nevertheless I am successfully using these renderers together with the SDL software renderer. (On most devices the SDL software renderer will be much faster as there are only badly optimized vendor drivers available) I send these patches now in this unpolished state because there seems to be some interest in win ce and someone has to start supporting SDL 1.3 Now on to the patches: wince_events_window_fixes.patch fixes some wince incompatibilities and adds fullscreen support via SHFullScreen. NOTE: This patch shouldn't have any side effects on Windows, but I have NOT tested it on Windows, so please double-check. This patch doesn't dependent on the following ones. wince_renderers_system.patch This patch does all necessary modifications to the SDL system. - it adds the renderers to the configure system - it adds the renderers to win32video SDL_ceddrawrender.c SDL_ceddrawrender.h SDL_gapirender_c.h SDL_gapirender.c SDL_gapirender.h these files add the new render drivers and should be placed in src/video/win32 Some notes to people who want to test this: - I have only compiled sdl with ming32ce, so the VisualC files are not up to date - As mingw32ce has no ddraw.h this file must be taken from the MS SDK and modified to work with gcc - I had to modify line 2611 in configure.in to EXTRA_LDFLAGS="$EXTRA_LDFLAGS -lcoredll -lcommctrl -lmmtimer -Wl,--image-base -Wl,0x10000" otherwise GetCPinfo wouldn't link. If someone knows whats causing this I'd be happy to hear about it. It would be great if these patches could make their way into SVN as this would make collaboration much much easier. I'm out of office for the next week and therefore will be unavailable via email. Regards Stefan
author Sam Lantinga <slouken@libsdl.org>
date Sun, 07 Jun 2009 02:44:46 +0000
parents df2bb5735822
children b7a48f533966
line wrap: on
line diff
--- a/configure.in	Fri Jun 05 23:36:00 2009 +0000
+++ b/configure.in	Sun Jun 07 02:44:46 2009 +0000
@@ -2077,6 +2077,18 @@
        ])
     fi
 
+    AC_MSG_CHECKING(Windows CE)
+    have_wince=no
+    AC_TRY_COMPILE([
+#ifndef _WIN32_WCE
+#error This is not Windows CE
+#endif
+    ],[
+    ],[
+    have_wince=yes
+    ])
+    AC_MSG_RESULT($have_wince)
+
     dnl See if the user wants to redirect standard output to files
     AC_ARG_ENABLE(stdio-redirect,
 AC_HELP_STRING([--enable-stdio-redirect], [Redirect STDIO to files on Win32 [[default=yes]]]),
@@ -2094,6 +2106,7 @@
                   , enable_directx=yes)
     if test x$enable_directx = xyes; then
         AC_CHECK_HEADER(d3d9.h, have_d3d=yes)
+        AC_CHECK_HEADER(ddraw.h, have_ddraw=yes)
         AC_CHECK_HEADER(dsound.h, have_dsound=yes)
         AC_CHECK_HEADER(dinput.h, have_dinput=yes)
     fi
@@ -2556,6 +2569,18 @@
             if test x$enable_render_gdi = xyes; then
                 AC_DEFINE(SDL_VIDEO_RENDER_GDI)
             fi
+            AC_ARG_ENABLE(render-gapi,
+AC_HELP_STRING([--enable-render-gapi], [enable the GAPI/RAWFRAMEBUFFER render driver [[default=yes]]]),
+                                , enable_render_gapi=yes)
+            if test x$enable_render_gapi = xyes -a x$have_wince = xyes; then
+                AC_DEFINE(SDL_VIDEO_RENDER_GAPI)
+            fi
+            AC_ARG_ENABLE(render-ddraw,
+AC_HELP_STRING([--enable-render-ddraw], [enable the Mobile DirectDraw render driver [[default=yes]]]),
+                                , enable_render_ddraw=yes)
+            if test x$enable_render_ddraw = xyes -a x$have_wince = xyes -a x$have_ddraw = xyes; then
+                AC_DEFINE(SDL_VIDEO_RENDER_DDRAW)
+            fi
             AC_ARG_ENABLE(render-d3d,
 AC_HELP_STRING([--enable-render-d3d], [enable the Direct3D render driver [[default=yes]]]),
                                 , enable_render_d3d=yes)