diff configure.in @ 1855:5ff2c01e475e

Moved DirectInput joystick code to 1.3 branch
author Sam Lantinga <slouken@libsdl.org>
date Sun, 21 May 2006 17:26:40 +0000
parents 2280e314a978
children d688ac43a76b
line wrap: on
line diff
--- a/configure.in	Sun May 21 16:47:41 2006 +0000
+++ b/configure.in	Sun May 21 17:26:40 2006 +0000
@@ -2270,13 +2270,8 @@
         fi
         # Set up files for the joystick library
         if test x$enable_joystick = xyes; then
-            if test x$have_directx = xyes; then
-                AC_DEFINE(SDL_JOYSTICK_DINPUT)
-                SOURCES="$SOURCES $srcdir/src/joystick/win32/SDL_dxjoystick.c"
-            else
-                AC_DEFINE(SDL_JOYSTICK_WINMM)
-                SOURCES="$SOURCES $srcdir/src/joystick/win32/SDL_mmjoystick.c"
-            fi
+            AC_DEFINE(SDL_JOYSTICK_WINMM)
+            SOURCES="$SOURCES $srcdir/src/joystick/win32/*.c"
             have_joystick=yes
         fi
         # Set up files for the cdrom library