diff configure.in @ 5029:5d7d48157be7

Greg Jandl to SDL I did some digging, and I think I've found a better solution. By including some additional .m4 macros in the acinclude directory (http://www.gnu.org/software/autoconf-archive/ax_check_compiler_flags.html, http://www.gnu.org/software/autoconf-archive/ax_gcc_archflag.html and http://www.gnu.org/software/autoconf-archive/ax_gcc_x86_cpuid.html) then using the patch below (same as previous patch + one line change to configure.in), SDL will build correctly out of the box. The arch can then be overridden by --with-gcc-arch=<arch> (most will probably want to build with i686 there for general distribution) or --without-gcc-arch, to disable setting the arch all together. On my Atom netbook, I get -march=PentiumPro by default, which works great, as does --with-gcc-arch=i686.
author Sam Lantinga <slouken@libsdl.org>
date Tue, 18 Jan 2011 22:40:45 -0800
parents 0c72ae7b7cb2
children 6a0803e47c7b
line wrap: on
line diff
--- a/configure.in	Tue Jan 18 22:10:37 2011 -0800
+++ b/configure.in	Tue Jan 18 22:40:45 2011 -0800
@@ -48,6 +48,7 @@
 
 dnl Detect the canonical build and host environments
 dnl AC_CANONICAL_HOST
+AX_GCC_ARCHFLAG([no])
 
 dnl Check for tools
 AC_PROG_LIBTOOL