diff configure.in @ 1657:5b0805ceb50f SDL-1.3

Merge trunk-1.3-2
author Sam Lantinga <slouken@libsdl.org>
date Fri, 28 Apr 2006 16:55:41 +0000
parents 0a53c90a37f9
children e49147870aac
line wrap: on
line diff
--- a/configure.in	Thu Apr 27 09:09:48 2006 +0000
+++ b/configure.in	Fri Apr 28 16:55:41 2006 +0000
@@ -52,6 +52,11 @@
 dnl Set up the compiler and linker flags
 INCLUDE="-I$srcdir/include"
 if test x$srcdir != x.; then
+    # Remove SDL_config.h from the source directory, since it's the
+    # default one, and we want to include the one that we generate.
+    if test -f $srcdir/include/SDL_config.h; then
+        rm $srcdir/include/SDL_config.h
+    fi
     INCLUDE="-Iinclude $INCLUDE"
 fi
 case "$host" in
@@ -2332,6 +2337,7 @@
         # use here or in sdl-config. Hence we reset it.
         EXTRA_LDFLAGS=""
 
+        CheckVisibilityHidden
         CheckDummyVideo
         CheckDiskAudio
         CheckDummyAudio