diff configure.in @ 242:4bcb29d3769c

Added support for Xi Graphics XME fullscreen extension
author Sam Lantinga <slouken@libsdl.org>
date Thu, 22 Nov 2001 04:55:38 +0000
parents b6084de9431a
children 9ac9ab945955
line wrap: on
line diff
--- a/configure.in	Thu Nov 22 03:47:16 2001 +0000
+++ b/configure.in	Thu Nov 22 04:55:38 2001 +0000
@@ -622,6 +622,26 @@
                     SYSTEM_LIBS="$SYSTEM_LIBS -lXinerama"
                 fi
             fi
+            AC_ARG_ENABLE(video-x11-xme,
+[  --enable-video-x11-xme  enable Xi Graphics XME for fullscreen [default=yes]],
+                            , enable_video_x11_xme=yes)
+            if test x$enable_video_x11_xme = xyes; then
+                AC_MSG_CHECKING(for Xi Graphics XiGMiscExtension support)
+                video_x11_xme=no
+                AC_TRY_COMPILE([
+                 #include <X11/Xlib.h>
+                 #include <X11/extensions/xme.h>
+                ],[
+                 XiGMiscResolutionInfo *resolutions;
+                ],[
+                video_x11_xme=yes
+                ])
+                AC_MSG_RESULT($video_x11_xme)
+                if test x$video_x11_xme = xyes; then
+                    CFLAGS="$CFLAGS -DHAVE_XIGXME"
+                    SYSTEM_LIBS="$SYSTEM_LIBS -lxme"
+                fi
+            fi
         fi
     fi
 }