diff configure.in @ 3696:47d923feedb0

Fixed bug #935 Patrice Mandin Hello, I originally added pth support for threads in SDL 1.2 because on the Atari platform we did not have any thread library. I think pth support could be removed from SDL 1.3 for two reasons: - Atari platform removed - pth does not provides real (preemptive) threads, because it is user space, and expect the application to call one of its function to give CPU to another thread. So it is not exactly useful for applications, that expect threads to run simultaneously.
author Sam Lantinga <slouken@libsdl.org>
date Sun, 24 Jan 2010 20:47:20 +0000
parents be6fe5f0b1db
children 1bceff8f008f
line wrap: on
line diff
--- a/configure.in	Sun Jan 24 20:21:51 2010 +0000
+++ b/configure.in	Sun Jan 24 20:47:20 2010 +0000
@@ -1694,33 +1694,6 @@
     fi
 }
 
-dnl See if we can use GNU pth library for threads
-CheckPTH()
-{
-    dnl Check for pth support
-    AC_ARG_ENABLE(pth,
-AC_HELP_STRING([--enable-pth], [use GNU pth library for multi-threading [[default=yes]]]),
-                  , enable_pth=yes)
-    if test x$enable_threads = xyes -a x$enable_pth = xyes; then
-        AC_PATH_PROG(PTH_CONFIG, pth-config, no)
-        if test "$PTH_CONFIG" = "no"; then
-            use_pth=no
-        else
-            use_pth=yes
-        fi
-        AC_MSG_CHECKING(pth)
-        AC_MSG_RESULT($use_pth)
-        if test "x$use_pth" = xyes; then
-            AC_DEFINE(SDL_THREAD_PTH)
-            SOURCES="$SOURCES $srcdir/src/thread/pth/*.c"
-            SOURCES="$SOURCES $srcdir/src/thread/generic/SDL_syssem.c"
-            SDL_CFLAGS="$SDL_CFLAGS `$PTH_CONFIG --cflags`"
-            SDL_LIBS="$SDL_LIBS `$PTH_CONFIG --libs --all`"
-            have_threads=yes
-        fi
-    fi
-}
-
 dnl See what type of thread model to use on Linux and Solaris
 CheckPTHREAD()
 {
@@ -1892,8 +1865,6 @@
             SOURCES="$SOURCES $srcdir/src/thread/pthread/SDL_syscond.c"
 
             have_threads=yes
-        else
-            CheckPTH
         fi
     fi
 }