diff src/main/Makefile.am @ 158:4382c38dfbee

Date: Tue, 21 Aug 2001 03:50:01 +0200 From: Max Horn <max@quendi.de> Subject: New patch for OS X Attached a .patch file for SDL/OSX with some nice bug fixes / enhancments. * fixes the activation issues, which also caused the window to be always drawn like an inactive. The close/minimize widgets now are animated properly, too. * the menu items are automatically adjusted to use the app name instead of just "SDL App". I did this so that we really can use one central SDLMain.nib file, w/o requiring developers to make a copy of it and adjust it. * libSDLMain now contains the proper cocoa code, not as before the carbon code. This means apps no longer have to carry a copy of SDLMain.m/SDLMain.h * revamped configure.in to properly build a Cocoa/Quartz SDL lib, not a Carbon based SDL lib
author Sam Lantinga <slouken@libsdl.org>
date Tue, 21 Aug 2001 07:19:59 +0000
parents 218325a2653f
children e92aa316c517
line wrap: on
line diff
--- a/src/main/Makefile.am	Mon Aug 20 04:41:49 2001 +0000
+++ b/src/main/Makefile.am	Tue Aug 21 07:19:59 2001 +0000
@@ -10,7 +10,11 @@
 # Build a separate library containing the main() entry point.
 lib_LIBRARIES = libSDLmain.a
 
+if TARGET_MACOSX
+MAINLIB_ARCH_SRCS = SDLmain.m SDLmain.h
+else
 MAINLIB_ARCH_SRCS = SDL_main.c
+endif
 
 libSDLmain_a_SOURCES = $(MAINLIB_ARCH_SRCS)