diff configure.in @ 3939:42e83d81224b SDL-1.2

Committed PulseAudio driver. Thanks, Stephan!
author Ryan C. Gordon <icculus@icculus.org>
date Sun, 13 May 2007 23:12:46 +0000
parents 00959c391aa6
children 9d9e15ab1697
line wrap: on
line diff
--- a/configure.in	Tue Apr 17 09:09:48 2007 +0000
+++ b/configure.in	Sun May 13 23:12:46 2007 +0000
@@ -459,6 +459,63 @@
     fi
 }
 
+dnl Find PulseAudio
+CheckPulseAudio()
+{
+    AC_ARG_ENABLE(pulseaudio,
+AC_HELP_STRING([--enable-pulseaudio], [use PulseAudio [[default=yes]]]),
+                  , enable_pulse=yes)
+    if test x$enable_audio = xyes -a x$enable_pulse = xyes; then
+        audio_pulse=no
+
+        PULSE_REQUIRED_VERSION=0.9
+
+        AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+        AC_MSG_CHECKING(for PulseAudio $PULSE_REQUIRED_VERSION support)
+        if test x$PKG_CONFIG != xno; then
+        if $PKG_CONFIG --atleast-pkgconfig-version 0.7 && $PKG_CONFIG --atleast-version $PULSE_REQUIRED_VERSION libpulse-simple; then
+                PULSE_CFLAGS=`$PKG_CONFIG --cflags libpulse-simple`
+                PULSE_LIBS=`$PKG_CONFIG --libs libpulse-simple`
+                audio_pulse=yes
+        fi
+        fi
+        AC_MSG_RESULT($audio_pulse)
+
+        if test x$audio_pulse = xyes; then
+            AC_ARG_ENABLE(pulseaudio-shared,
+AC_HELP_STRING([--enable-pulseaudio-shared], [dynamically load PulseAudio support [[default=yes]]]),
+                          , enable_pulse_shared=yes)
+            if test "x`echo $PULSE_LIBS | grep -- -L`" = "x"; then
+                if test "x`ls /lib/libpulse-simple.so.* 2> /dev/null`" != "x"; then
+                    PULSE_LIBS="-L/lib $PULSE_LIBS"
+                elif test "x`ls /usr/lib/libpulse-simple.so.* 2> /dev/null`" != "x"; then
+                    PULSE_LIBS="-L/usr/lib $PULSE_LIBS"
+                elif test "x`ls /usr/local/lib/libpulse-simple.so.* 2> /dev/null`" != "x"; then
+                    PULSE_LIBS="-L/usr/local/lib $PULSE_LIBS"
+                fi
+            fi
+            pulse_lib_spec=`echo $PULSE_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libpulse-simple.so.*/'`
+            pulse_lib=`ls -- $pulse_lib_spec | sed 's/.*\/\(.*\)/\1/; q'`
+            echo "-- $pulse_lib_spec -> $pulse_lib"
+
+            AC_DEFINE(SDL_AUDIO_DRIVER_PULSE)
+            SOURCES="$SOURCES $srcdir/src/audio/pulse/*.c"
+            EXTRA_CFLAGS="$EXTRA_CFLAGS $PULSE_CFLAGS"
+            if test x$have_loadso != xyes && \
+               test x$enable_pulse_shared = xyes; then
+                AC_MSG_WARN([You must have SDL_LoadObject() support for dynamic PulseAudio loading])
+            fi
+            if test x$have_loadso = xyes && \
+               test x$enable_pulse_shared = xyes && test x$pulse_lib != x; then
+                AC_DEFINE_UNQUOTED(SDL_AUDIO_DRIVER_PULSE_DYNAMIC, "$pulse_lib")
+            else
+                EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PULSE_LIBS"
+            fi
+            have_audio=yes
+        fi
+    fi
+}
+
 CheckARTSC()
 {
     AC_ARG_ENABLE(arts,
@@ -2150,6 +2207,7 @@
         CheckALSA
         CheckARTSC
         CheckESD
+        CheckPulseAudio
         CheckNAS
         CheckX11
         CheckNANOX