diff configure.in @ 2472:3f73c88c9abb gsoc2008_force_feedback

First commit of the SDL_haptic subsystem. Code compiles and works, very limited functionality (linux only).
author Edgar Simo <bobbens@gmail.com>
date Sun, 01 Jun 2008 11:44:25 +0000
parents 33052794de27
children 3f80bf1528b4
line wrap: on
line diff
--- a/configure.in	Wed Apr 23 06:26:07 2008 +0000
+++ b/configure.in	Sun Jun 01 11:44:25 2008 +0000
@@ -235,6 +235,14 @@
 else
     SOURCES="$SOURCES $srcdir/src/joystick/*.c"
 fi
+AC_ARG_ENABLE(haptic,
+AC_HELP_STRING([--enable-haptic], [Enable the haptic (force feedback) subsystem [[default=yes]]]),
+              , enable_haptic=yes)
+if test x$enable_haptic != xyes; then
+    AC_DEFINE(SDL_HAPTIC_DISABLE)
+else
+    SOURCES="$SOURCES $srcdir/src/haptic/*.c"
+fi
 AC_ARG_ENABLE(cdrom,
 AC_HELP_STRING([--enable-cdrom], [Enable the cdrom subsystem [[default=yes]]]),
               , enable_cdrom=yes)
@@ -2176,6 +2184,16 @@
             ;;
           esac
         fi
+        # Set up files for the haptic library
+        if test x$enable_haptic = xyes; then
+          case $ARCH in
+            linux)
+                AC_DEFINE(SDL_HAPTIC_LINUX)
+                SOURCES="$SOURCES $srcdir/src/haptic/linux/*.c"
+                have_haptic=yes
+            ;;
+          esac
+        fi
         # Set up files for the cdrom library
         if test x$enable_cdrom = xyes; then
           case $ARCH in